View Single Post
10 Oct 2010  

Windows Ultimate 32bit
Toshiba A135 USB error - PLEASE HELP!

Okay, so I have a Toshiba A135 S2636 which was running Windows Vista up until last week.... When my USB ports went bananas on it and I was unable to navigate with even the onboard mousepad I decided that it was time to upgrade. This computer is supported by Toshiba to upgrade to Win7, and Ive updated it fully with all the support that Toshiba offers for this model. For the first two days the USB devices worked just fine and then they started to go finicky again, with the computer reporting that the USB had malfunctioned. At first a restart worked and then that stopped to, so I began the long list of troubleshooting. I followed all of Windows suggested fixes and none of them worked, I unplugged the computer and took out the battery to 'restart' the motherboard.. that didnt work. I deleted the devices and turned of the computer, they were reinstalled on restart and that didnt work either. I then went into the BIOS and turned off the legacy USB hardware which worked for about 2 days and then as soon as the computer went to sleep it refused to work yet again. I am at wits end - for as a student with carpal tunnel it is crucial that I use my ergonomic keyboard for my papers and assignments.... But it is not useable with my USB ports down.

I am desperate and I have run out of options for searching on forums, and google.

Ill run any tests you need, and do anything, but I have exhausted every option ive found on google. Im thinking I now need the help of someone who is far more techy and Windows 7 savvy then I.

Thanks in advance!
My System SpecsSystem Spec