View Single Post
24 Nov 2010  
ODBOD

Windows XP//Windows 7 Ultimate RTM
 
 
Mouse Locking Up Randomly

Alright, so I've had this standard 3-button logitech mouse for about a few years now (M-BT96A) and the left click finally decided to die on it. So, I decided to take the mouse from my spare PC (same exact hardware as my main PC) and use it. It's a logitech mouse as well (M-UR69). Now, here's when the problem comes in.

Originally, I had my original mouse on a USB to PS/2 converter. It's always how I've done it to have most of my USB ports open, even back several years ago. I tried putting the mouse from the spare computer on said PS/2 converter, but it doesn't even power on at all when the computer turns on. So I had to resort to putting it into a USB port.

So I do so. I start going through my normal business, checking email, playing a game of starcraft and that's about it. And then I notice, it's locking up. During StarCraft, when I moved my mouse, it locked in place for one or two seconds and then finally resumed back to where I was moving it to. I noticed this immediately and when I got the game finished, I started looking it up on google. Lo and behold, it does the freezing thing again. And it isn't a pre-determined time it does it either. Understand, it's happening at random instances.

Some forums have said that certain services or event logs can tell you what's going on and what would cause it. However, nothing is ever starting or stopping or no activity is occuring when the brief halt occurs.

I started troubleshooting, removing it from device manager, reinstalling it normally through 'scan for hardware changes'. Still no go. Now I'm stuck with a mouse that locks up randomly and such and I can't do a thing about it. It's a nuisance and why I can't fix it, I don't even know.

This is what I've tried:

-Put the mouse back on my spare PC (same hardware as I mentioned before) and logged into Windows (Windows 7 ultimate 64 bit). No hitching. Nothing. Standard movement, everything is good.
-Tried other mice I could find (older USB ones that I don't like too much/are not comfortable/ones that my dad uses) and they don't even hitch. At all. Everything works like a charm for them. Even plugged into the PS/2 converter, they work beautifully.
-Replugged my old mouse and tried using it (left click is pretty much a dud, I have to slam on it to click) and it worked without hitching.
-Tested other USB ports. Same results.

So now I'm at a loss because I don't understand how I can fix this or get around this. I could buy another mouse, but I don't really have the money to do that at the moment. I just want to solve this issue. What should I do?

Thank you.
My System SpecsSystem Spec