View Single Post
02 Dec 2010  
janw

Windows 7 Enterprise x64
 
 
DNS problems after connected to public network

Hi!

I've got the following problem on my Lenovo ThinkPad SL510 running Windows 7 Enterprise x64:

When running my PC in my home network everything works fine. I can ping IPs on my network and i can ping their hostnames.

However, when I have been logged in into the wifi network at my school (WPA2-Enterprise) and return home (and logon to my home network), I am not able to ping or connect directly (via Windows Explorer) to the hostnames anymore. Using the IP instead works fine. I can only get rid of this problem if I do a system restore (Start Menu -> Accesories -> System Tools -> System Restore) using a restore point created before I logged into the school network. This problem is reproducable!

I have tried allready:
- ipconfig /renew
- flushing dns cache
- deleting the school network
- disabling IPv6 on all network adapters
- changing the network node type to "Hybrid" via registry - seems the school network changes this setting


I seriously doubt that this problem has something to do with either my router or the other hosts in my network.

This is the ipconfig /all output at the time the problem occurs:
Code:
Windows IP Configuration

   Host Name . . . . . . . . . . . . : sl510
   Primary Dns Suffix  . . . . . . . : 
   Node Type . . . . . . . . . . . . : Peer-Peer
   IP Routing Enabled. . . . . . . . : No
   WINS Proxy Enabled. . . . . . . . : No

Wireless LAN adapter Wireless Network Connection:

   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Intel(R) WiFi Link 1000 BGN
   Physical Address. . . . . . . . . : 00-26-C7-60-D6-3E
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes
   Link-local IPv6 Address . . . . . : fe80::1c43:a971:5e7f:113a%13(Preferred) 
   IPv4 Address. . . . . . . . . . . : 192.168.0.12(Preferred) 
   Subnet Mask . . . . . . . . . . . : 255.255.255.192
   Lease Obtained. . . . . . . . . . : Donnerstag, 2. Dezember 2010 17:08:14
   Lease Expires . . . . . . . . . . : Freitag, 3. Dezember 2010 17:08:15
   Default Gateway . . . . . . . . . : 192.168.0.1
   DHCP Server . . . . . . . . . . . : 192.168.0.1
   DHCPv6 IAID . . . . . . . . . . . : 318777031
   DHCPv6 Client DUID. . . . . . . . : 00-01-00-01-14-81-D8-85-60-EB-69-38-AD-35
   DNS Servers . . . . . . . . . . . : 213.191.74.11
                                       213.191.92.82
   NetBIOS over Tcpip. . . . . . . . : Enabled

Ethernet adapter Local Area Connection:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Realtek PCIe GBE Family Controller
   Physical Address. . . . . . . . . : 60-EB-69-38-AD-35
   DHCP Enabled. . . . . . . . . . . : Yes
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{E7B82ABE-DC9D-4C11-A0BD-7ECAB27EA4DD}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter Local Area Connection* 11:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft Teredo Tunneling Adapter
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{18DAD967-A1E6-4538-81BB-AEBE6522FCBD}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #2
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{78BEBDF9-6BA3-469C-8CC8-D141518DE791}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #3
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes

Tunnel adapter isatap.{EC5DDBF7-5517-4CBB-9C48-7E54695A5D1A}:

   Media State . . . . . . . . . . . : Media disconnected
   Connection-specific DNS Suffix  . : 
   Description . . . . . . . . . . . : Microsoft ISATAP Adapter #4
   Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
   DHCP Enabled. . . . . . . . . . . : No
   Autoconfiguration Enabled . . . . : Yes
Please help me!!! Thank you all!

Regards,

Jan
My System SpecsSystem Spec