View Single Post
28 Feb 2011  
NoooneyDude

Windows 7 Professional 32bit
 
 
Issues with recent Windows Update

Hey everyone,
I've been having an issue with a Windows 7 Update, I think it was either a Critical Security Update, or Critical Windows Update.

I had several updates to install, so I installed them, then it wanted me to restart the computer, which I did. Upon booting, I get a quick glance of the dreaded BSOD, and the computer restarts, and comes up with Startup Repair, and asks me if I wanted to use System Restore. I click yes, and after a while my computer restarts without problems, and I can actually log into Windows. A dialogue box appears, saying that "System Restore did not complete successfully, your computer's files and settings were not changed", yet that cannot be true because I noticed some software restored, which I had previously uninstalled.

I managed to find what update was causing the problem using the process of elimination, several restarts and system restores, and could install every other update without a problem.

However, a few days later, I again get the BSOD during startup. So I thought that that update had gotten installed somehow, and restored two days earlier. But this time it was not a success. I still could not boot Windows. So I restored to even earlier date, and now I could get to the Login screen. I tried to login, but it gave me a temporary account, so I logged out and tried to login again. Same result, but a restart fixed this.

Now some of my software is corrupted. (Java, Microsoft Word, Google Chrome, Skype and a couple of others). I know that all the corrupted software was installed before the date that I had restored to, so System Restore was not the fault, right?

I managed to successfully reinstall all of my software, except Java. When I tried to reinstall it, a dialogue box would appear, saying;
"This software has already been installed on your computer. Would you like to reinstall it?"
I click yes, and two errors pop up, which I have forgotten. So I completely delete the Java directory in Program Files, but no change. I then used CCleaner, but no difference. As a third attempt, I rummaged through the Registry deleting anything to do with Java. This took awhile, but I made some progress! Now, I get to the Java Installer window, where it shows the progress bar, I get the error message;
"The system cannot open the device or file specified."
I click cancel. Another error message pops up, saying;
"Internal error 2755. 110, C:Users\David Campbell\AppData\LocalLow\Sun\Java\jre1.6.0_24\jre 1.6.0_24-pfrom23.msi."
Did I delete too much in the registry?

How can I fix this problem?


Another problem, is that I cannot play any of my music! Even if they are off a CD! It's as if the music plays, but I cannot hear any sound. I thought that it might be a corrupted Windows Media Player, so I downloaded and installed VLC Media Player to see if that made a difference, but it does exactly the same thing. I don't think it's a driver issue, because Windows 7 sounds and sites like YouTube still plays audio.


And also, I cannot check for updates. When I click the Check for updates button, it displays the progress bar but after a minute or so goes back to the Check for updates for your computer screen.


Would it just be easier to completely reinstall Windows 7? (It would be a pain and a hassle)

Thanks in advance
My System SpecsSystem Spec