View Single Post
05 Jun 2011  
PancakeDevourer

W7 Ultimate x64
 
 
PC is not accessible

I recently changed ISPs, and in the process decided to upgrade my router as I have been wanting a gigabit one. Well everything went fine, set up all my PCs as required (needed to forward a few ports for a few applications). Somehow though I have encountered a problem.

I have two Windows 7 Ultimate x64 PCs, which I have networked together. I am able to login with a remote desktop connection just fine, I am able to access the homegroup section fine too. But the section under "Network" doesn't work. Well it works in that I can see PC1 and PC2, but if I click on the remote PC. I get the error:

\\PD-PC is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
The remote procedure call failed and did not execute.


They are on the same router and subnet, and wired if it matters. They are actually the only two things plugged into it, all other PCs use the FiOS provided router. My router is the D-Link DGL4100. No third party firewalls, just the Windows one (and the router one). Prior to the change in routers, everything worked fine.

I have searched around the internet, and almost every thread I go to seems to have a different "fix" for this, none have worked for me. I am stumped. I am sorry if I have forgotten to provide you with some information that would help
My System SpecsSystem Spec