View Single Post
17 Aug 2011  
150001

Windows 7 Home Premium 64 bit
 
 
Stuttering on Games

Hi there

I am starting to lose patience with my laptop. Since the beginning of August, my games have started to stutter in gameplay. It is driving me mad now. This never happened before the end of July. I got my laptop in May 2011, and it was fine through May, June and July. Is the problem the sound card, the graphics or something else. I have installed the latest driver ( I think. Something called Catalyst Mobility Suite). My Acer aspire 5920g never did this and I do wish I had not spilt drink over it. I've already tried lowering the settings on games, I've tried software like Gamebooster and the framerates are fine. Running around 70 to 85 fps on most games. It is just that there is stuttering about every 40 seconds. My only guess now is that it is the sound card. The games that are stuttering badly are City bus simulator 2010, Openbve (freeware train sim), Railworks 2. There are very few and little stutters in Ship simulator 2008 and in Ship Simulator extremes, Bus driver gold and 18 Wheels of steel extremes 2, are working as usual!

My computer is a Hp pavilion dv7 4144ea.

ATI Mobility Radeon HD 5470
with 512 MB dedicated memory
2.20 GHz AMD Athlon II P340 (2 cores)
4 Gb RAM
17.3 inch Glossy LCD (LED-lit) (1600x900 px / 16:9)
IDT audio HD. With altec lansing speakers and dolby advanced audio
Windows 7 Home premium 64 bit.

Other specifications here

Index of /product-specifications-and-comparison/ ... -shopping/

Has anyone got ideas how to solve the stutters. The framerates are fine and they don't go even if the game or ATI catalyst is on low settings. Please help. I have no idea why this has suddenly come on as it was happening before.

Thanks in advance

P.S Please could you explain not in too much technical terms.
My System SpecsSystem Spec