Thread: RAM problem...
View Single Post
23 Aug 2011  
Coke Robot

Windows 7 Ultimate x64
 
 
RAM problem...

Salutations.

Today I got in the post my 8 gig G.Skill DDR3 1333Mhz dual channel kit from Newegg, and I was really really stoked about having 8 gigs of RAM with a 7 CAS latency and all, but when I popped that kit in my madreboard and tried to boot into Windows, it epically failed.

So here's what I all did:
-checked in BIOS to see if the RAM's recognized, it is
-changed the RAM voltage to 1.5, no go
-changed the timings, no go
-changed the frequencies, no go again
-did a combo of the three, no go
-booted into Safe Mode, that worked and Windows is seeing 8 gigs installed
-haven't done a memtest yet but I will
-took a stick out and booted into Windows and it worked but the timings are at 9 even though I changed it to 7

I'm thinking it's not a RAM problem but more a BIOS being outdated it seems. I binged around a bit and found a support thread with pretty much the same issue and symptoms and a BIOS update helped, but I don't want to risk killing my motherboard unless I know for sure it will help. So does anyone have suggestions?

Also, I think CPU-Z is off a bit because it detected my northbridge chip as being an AMD 780G when it's a 760G. I don't know...
My System SpecsSystem Spec