View Single Post
07 Nov 2011  

Windows 7 64-bit
"Windows failed to start..." Recovery disk is unable to recover Win.

Hi all. Earlier today I was playing around with Windows 8 Developer Preview inside of Virtualbox. I tried to install the VB guest additions (which allows copy-paste between guest and host, as well as other things) and was told to restart the computer. So I restarted the VM and got the new version of the BSOD saying something or other that I cant remember now. After trying to fix it with the recovery tool that came with the Win8 installer, I just chose to reset it because I hadn't really done anything. So I reset it, whoopdie-doo, and kept messing around with it. After a while I got bored of the ugly Metro UI and went back to Windows 7 ( I just closed the VM).

Now that I've bored you enough with background info, here's my problem. I reboot my laptop and I can't boot... "Windows has failed to start. A recent hardware or software change might be the cause. To fix this problem: <instructions in how to use the recovery disc to repair the computer>. If you do not have this disc, contact your system administrator or computer manufacturer for assistance. File: \Boot\BCD Status: 0xc000000f Info: An error occurred while attempting to read the boot configuration data."

So, I whip out my handy-dandy thumb drive that can boot into live Kubuntu, Fedora, GParted, and the Windows 7 x64 recovery disk. I've used the recovery disk before to fix my MBR a while back and it worked perfectly. So I assumed it would do its thing now.... right? Wrong. It searches for Windows installations, and then right off the bat tells me its found errors with my startup options and wants to repair my computer. I say yes, and am immediately told that it "failed to save startup options". There is no OS in the list of discovered Windows installations but it lets me go to "System Recovery Options" where I can pull up a command prompt. After CDing around a bit, I find my Windows hard drive in E:. Then I noticed that the hard drive didn't even have a \boot folder.

Then I started Googling around and came across this. I followed the instructions in options 2 and 3 (after creating a new E:\boot folder) but they did not work. In option 2, after running bootrec /rebuildbcd, it found E as a windows installation, said it would add it to the boot list, and then told me "the requested system device cannot be found." In option 3, everything goes well until I execute "bcdedit /import E:\Boot\BCD.temp" and I am told "the store import operation has failed. The requested system device cannot be found." And this is really frustrating. It seems like the recovery disk is only detecting my hard drive when it feels like it!

But wait... that got me thinking. Why would the recovery disk do something like that? So, thanking my insight to keep GParted Live on a nearby USB, I spun it up to see what I could see. And, lo and behold, there is a little yellow error icon next to /dev/sda2 (my main partition with windows 7). I right clicked to read more about it, and got a big warning saying "Cluster XXXXXXX is referenced multiple times!" multiple times, and finally "ERROR: Filesystrm check failed! ERROR: 28 clusters referenced multiracial times. NTFS is inconsistent. Run chkdsk /f on Windows then reboot TWICE!" So I booted back into the recovery disc and hoped it had chkdsk.

It did. I've only run the read-only chkdsk in fear of messing something up. Is that possible? Or is it safe? Anyways, chkdsk told me "Attribute record <...> is corrupt" a couple times and eventually finished the first stage. Since it was in read-only mode it didn't continue to the next stages. One weird error chkdsk reported at the very end was "Failed to transfer logged messages to the event log with status 50."

Oops, and there I go again. Sorry for the bit lengthy post there. Please try to understand what this post is about and, if you can, offer some help on what I can do to get myself put of this predocament. Thanks!

EDIT- please pardon my spelling and formatting. I'm typing this all up on my android smartphone.
My System SpecsSystem Spec