View Single Post
16 Dec 2011  
aegero

Windows 7 64 Home Premium
 
 

I have exactely the same problem as You!
I first used a TP-link in the one and only PCI-Express-16-slot. Worked perfect in my Acer Aspire M5800. Then my grafic card broke down and the new blocked the slot! So I changed to D-link DWA 525 full PCI but cannot make it work . Hope someone can help us!

Anders
Sweden

Quote   Quote: Originally Posted by malaykeshav View Post
I just bought a D-Link PCI card for wireless Internet (DWA 525 , Wireless N 150 Desktop PCI adapter).
I installed the adapter and the driver on my PC, surfed the Internet for hours.
But the next day , when i tried connecting to my Router , it wouldnt connect. ("Windows is unable to connect to <SSID>")

Here are the things I have tried ::
1)I am able to connect to the same router , using my laptop and 2 wifi enabled mobile.
2)I tried changing the SSID , the encryption type (even keeping it open). Still couldnt connect.
3)Reset my router , and tried to connect with its default setting.
4)Tried connecting to a manually created adhoc connection via my laptop as well as my android device (Hotspot), and connected to them successfully.
5)Updated the firmware on my router and installed the latest driver for the adapter.
6)Tried connecting to the same by booting into Ubuntu.
7)Tried connecting using various wireless network connection softwares.


Wireless Adapter :: D-Link Wireless N 150 Desktop PCI Adapter
Router :: Netgear DGN1000 wireless router
Windows 7 64 Bit

Where is the problem!?
is it the router settings ?
or my PCI card ?
My System SpecsSystem Spec