View Single Post
16 Jan 2012  

Windows 7 Professional 64x (SP1)
USB Wireless dongle freezes wireless until explorer restart/removal

A while back i purchased a Tenda wireless dongle and started to use it instead of a very long winded wireless to wired connection bridge between two computers. Anyway, the dongle was suggested by a housemate who uses the exact same model and make on our wireless hub in the house. Everything was fine until a few weeks after purchase it started to have issue connecting particularly after restart. I tore several clumps of hair out trawling the internet to find a cure to the issue... A friend even lent me a unique dongle but it provided a temporary fix before following in the same footsteps. I even tried both dongles (identical in make and model) across the two PC's on the network they belonged to. On both occasions each dongle connected instantly and without issue on the other PC and took a long time and eventually failed on my PC. Finally i give up and went as far as re-installing windows 7 fresh and slowly installing everything again including the dongle.

Everything was fine... (approximately 2-3 months) until tonight were its decided to tell me that it cant find the network im trying to connect. My housemate however is currently connected to the network fine, and the PC with the same dongle connects as always without a hitch. I've tried restarting both the wireless hub, the dongle the computer the drivers disabling and re enabling everything that can possibly be connected with internet.

Whats weird is it does however find my network and a few others occasionally, when it does i click connect and it freezes the wireless frame and anything to do with the wireless settings in windows. This is only unfrozen when i either restart the PC or the adapter is removed. I did try the troubleshoot tool provided by windows 7 however this either tells me everything is fine... or normally because my network is not present it wont go any further until i try and connect.

When i choose to remove the adapter (physically)... everything unfreezes and it continues for a bit as if everything is fine... and then realises its been removed and disconnects. Like for example when i first uninstalled everything and removed all my saved networks it obviously asked me for the security code but only once i removed the dongle... which was helpful, Not.

What confuses me more is it randomness... it sometimes shows the networks sometimes it doesnt, It just there now while writing this and attempting to fix it allowed me to enter the security code.. but once i hit enter it proceeded to hang. I tried the troubleshooter which as this point just replied with it cannot identify the problem. Couple this with the fact that between today and yesterday.. i have changed nothing about either the USB or the router.. and i keep my computer protected with AV and firewall. (and yes i have tried temporarily turning these off incase they are interfering with the device, and also different USB slots)

I'm a techy kinda guy and i enjoy the puzzles of troubleshooting but this ones got to the point where im gonna end up with a large credit card bill as i completely change my computer, and i cant afford that to be frank

Device is working correctly and present in device manager.
All combinations of devices and drivers have been used with no resolution
Repaired and troubleshooted/restarted devices connected with wireless/computer
Issue is not repeatable and erratic at best, no definitive causality...

USB Model is Tenda W322u v2.0 (although i don't feel its relevant but i will be asked :P)
Windows 7 professional 64x (All recent updates, SP1)
4GB ram
i5 @2.67 (No overclocking)
NVIDA GeForce GTX 275
650W Power supply
Kept well cool via a multitude of fans and filters

Any other information required just say if you want i'll do an ipconfig and post also (:
My System SpecsSystem Spec