View Single Post
16 Feb 2012  
MightyWombat

Windows 7 Home Premium 64
 
 
Not able to change ownership on external sata drive

Hi,
I've googled and tried many methods to fix this over the last two hours but nothing so far as worked.

I have an old hard drive with data on it from my old Windows XP Professional computer attached to a usb port on a converter. Win 7 claims it cannot display the owner, if I try to take permission it says permission denied.

If I take down the UAC the hard drive no longer appears in My Computer.

I have tried to go in as the administrator account specifically it keeps giving me access denied. I tried using the administrator account in normal mode and using the command line 'take owner' command and it says access denied.

I tried going into administrator safe mode, but again the external hard drive won't show up.

Shortly I am planning on reformatting the current C drive and putting on Windows Xp Pro 32 bit, Win 7 and Ubuntu. Should I just wait till do that and hope it will miraculously identify it if I take control of it with Xp Pro? I'm really hoping this isn't going to indicate problems sharing files between the two operating systems on the same hard drive. Any thoughts on this would also be appreciated.

Other info: I'm using Windows Home Premium 64 Bit. There are two internal hard drives currently. The external hard drive keeps showing up as drive Q for some reason.

Thanks ahead of time for your help
My System SpecsSystem Spec