View Single Post
24 Feb 2012  

Windows 7 Home Premium 64bit
Dell N5030:W7 wont start. Dell logo + black screen. Factory reset how?

Dell N5030: W7 wont start. Dell logo > black screen. How to restore?

Hello friends

Please could you advise me. My friend has asked me to help with her Dell N5030 Inspiron laptop. She has had it for about just over a year now. Dual-core Pentium, 4GB RAM, W7 64bit. She is not computer savvy and I dont know how shes managed to do this but heres the problem:

1. You press the power button
2. The Dell logo appears along with the F2 & F12 options for Setup & Boot Options
3. This is followed by a black screen with a blinking cursor in the upper left. Thats it.

All this happens in the space of 6 seconds (power-up to black screen). Nothing else happens, no Windows logo screen, no Microsoft logo, nothing. Screen stays black with the cursor and the laptop instantly turns off when I press the power button.

My friend was desperate because she had over 740 family photos and some important documents she didnt want to lose. I was able to recover all of those using a Linux Mint live CD so at least shes all smiles for that

Using Mint made me realize that the hardware was working perfectly. The hard drive was good, no mem faults and of course the optical drive was fine. So its something with Windows 7.

Also while using Mint I could clearly see the Dell Recovery Partition. The problem is I dont know how to get the Inspiron to fire it up - because I cannot even get into Safe Mode where the "Repair your computer" option is.

When I pressed F12 all that comes up is an option to tweak the boot order and a diagnostics option. I ran the latter and it found no hardware faults at all. I wasnt surprised.

I tried the usual tricks for trying to get it to begin the factory reset. Stuff like: CTRL +F11, hold F5 down and then press power button, keep 0 pressed and then press power button. All of these do the same thing - they just start the Diagnostic Tests!

My friend says Dell did not provide a Restore DVD because they told her "it was all on the hard drive". But they assumed that the user would be able to get to the Advanced Boot Options screen - which is not happening.

Pressing F8 results in the Insipiron once again running its diagnostics. Safe Mode is not working.

How do I get this laptop to begin the factory reset? Thanks very much for any help you can give
My System SpecsSystem Spec