View Single Post
01 May 2012  
littleraskol

Windows 7 Home Premium 64 bit
 
 
Laptop cannot boot into Windows, possible 0xc000000f boot failure

First, some system specs: This is about a stock ASUS K50ID laptop, so the specs are as listed in this Newegg description.

The very basic description of the problem is that whenever I turn on the laptop, it seems to boot into Windows 7, in that the "Starting Windows" text appears and the little animation of colors forming the logo shows, but as some point it fails. This message appears on screen:
autocheck not found - skipping AUTOCHECK
After a few seconds a BSOD shows up, but too fast for me to make out what it says. It used to, but after some hasty fix attempts no longer does, cycle around to a menu that informed me of this error:
Status: 0xc000000f

Info: The boot selection failed because a required device is inaccessible.
Here's the longer history:

As some point in the past I decided to try out dual-booting Win7 and Linux on the laptop. I got it to a state where this worked fine. I had partitions roughly as follows:
[Ubuntu][Windows 7]([Data and files][Boot])
The parentheses denote a logical partition. The Boot partition was very small and only held what was necessary to launch GRUB. This week, I realized that I hardly ever used the Linux partition and decided to get rid of it to reclaim storage space. This is where the trouble begins. I rebooted into a thumb drive that could run GParted and modified the hard drive layout in the following steps:
  1. Delete the Ubuntu partition
  2. Delete the Boot partition
  3. Grow the Data/Files partition to take up the space left by Boot
  4. Shrink the Windows 7 partition to make it faster to move
  5. Move the Windows 7 partition to the front of the volume
  6. Expand it to take up the remaining space.
What I ended up with was:
[Windows 7]([Data and files])
My naive and fatal mistake was to trust that the Windows Repair CD could fix any boot issues, and also that there would be no catastrophic hardware failures. Both of these assumptions turned out to be false.

First, the laptop's CD/DVD drive has either broken or is too unreliable to use. I have noticed it becoming more and more unstable over time, but now (when I need it most!) it simply does not seem to want to spin up and function at all. This forced me to create a Windows Repair USB drive. However, I can't load any installation media. This is because the laptop did not come with an install DVD. It had a recovery sector, which I cannibalized for the Linux partition. I did copy the stock recovery stuff to a series of DVDs, but, well...

This is all to say that any solution that requires a DVD drive is straight out until I can replace it, which I'd like to consider a last resort.

My expectations for the Windows Repair CD/USB have been dashed. Attempting to automatically fix boot issues either fails for some specific reason (I can probably reproduce it and provide the details, if necessary), with a dialog to send a report, or fails because it cannot detect any problems. I have tried a variety of things based on my own research to fix this through the command prompt:
  • Running chkdsk /x /r on all drives. Does not find any errors.
  • Running various bootrec commands: /fixmbr, /fixboot, /rebuildbcd, /scanos. All complete successfully, but the last 2 report finding 0 Windows installations.
  • Using bcdboot and bootsect to recreate the bootloader. Again, no errors result, but it does not fix the issue.
I guess it should have been obvious that none of the boot record fixes would matter, since the laptop does boot into Windows 7, briefly.

I understand that this is a pretty bad problem. I would not be surprised if the only thing to do is get a new DVD drive to load the recovery DVDs I made. However, since this problem was caused by a software operation (in GParted), I'm hoping there is still some software solution. Alternately, it would be good to know if know recovery is possible, DVDs or not.
My System SpecsSystem Spec