View Single Post
23 Jun 2012  
Powell41

Windows Home Premium, 64 4.096 bit
 
 

Purchased a Seagate USB HD for backup a little over a year ago while I was running Vista. It ran okay for a little over a month and then it started to deny access to update the files. Finally it got to the point that when I ran a reboot or a cold boot I would get the Seagate screen but couldn't gain access to it or my computer. Tried to contact Seagate but my e-mails were ignored. Reinstalled my O/S and quit using it. After running Windows 7 for a while I decided to give it another try. It ran for one download cycle and after that it completely blocked access to MS Office and it weould not uninstall. The last I saw of it, it was on its way to the dump. I'll rely on backing up my data on DVD disks.
As for running windows backup, I've tried it three times and each time it comes up with a different reason why it can't install. The system never mentions this until the transfer is almost completed. (Can't read a brand new disk [more than one], disk has corrupted sectors (strange since I can still fill up the disk with other data and retrieve it), and a simple transfer failed. It has been removed from the Action Centre. I'll rely on backing up my data on DVD disks.

Hope you have better luck than I did.
Powell Lucas
My System SpecsSystem Spec