View Single Post
21 Nov 2012  
dxm

Windows 7 Ultimate 64-bit (Service Pack 1)
 
 
Creating a new file in C: drive gives error 0x80070522

If I try to create a new file in C: drive, I get this error:
Error 0x80070522: A required privilege is not held by client.
I first noticed this error after doing a 'frugal' install of BackTrack 5R3 (Linux distribution) setup on C: using UNetbootin. I thought it must be preventing me from creating files so that they don't interfere with the Backtrack setup.

I ran the setup, but did not install BackTrack. And after that, I installed UNetbootin. Uninstalling removed newly-created 'frugal' install files and UNetbootin boot entry.

UNetbootin had changed permissions for C: (It seemed so). I tried to revert them manually by changing one permission from 'Applies to: Subfolders and filers' to 'Applies to: This folder, subfolders and files'.

On some forums (including Microsoft Answers), people were recommending to use
takeown and cacls. That did not solve my problem. And the commands they suggested applied on all subfolders and files as well. I have no problem with subfolders.

The previous Owner was 'TrustedInstaller'. After using
takeown, icacls and cacls, I could not revert the Owner back to TrustedInstaller, or to SYSTEM (as the owner of other partitions is 'SYSTEM') using command-line.

I have checked the permissions and the permissions for C: seem to be the same as for D: or E:, and they work fine.


And, yes, a point of note:

This error appears when I try to create a file by using
Right-click > New > Text document. Or when I use notepad (or any other application) to save to C: drive. But, if I run notepad (or other applications) as administrator, the file is saved without error.


UPDATES:

- System Restore does not solve the problem.

My System SpecsSystem Spec