View Single Post
03 Jan 2013  
bkl

Windows 7 Pro x64
 
 
Solved - AVG IPv6 DNS Name Resolution Timed Out - DNS Client Events

Here is a weird one that I just solved and wanted to pass along in case it may help someone else. I'm running AVG Antivirus paid version, but the free version would likely have the same problem. Windows 7 Pro. The problem also showed up on a brand new Windows 8 Pro box.

I had recently started getting a Windows System Log warning that said "Name resolution for the name update.avg.com timed out after none of the configured DNS servers responded". This was showing up as a "warning - DNS Client Events" with event ID 1014. The laptop was logging about half a dozen of the events a day. The laptop was working just fine otherwise, no problem with web browsing or email which made the DNS warning kind of puzzling. AVG also seemed to be working fine and would update OK when I did a manual update.

It turns out that AVG is doing something either odd or clever, depending on how you look at it, with their updates and DNS servers. They are using normally unused records in the DNS server entries to store the version number of the latest antivirus update. That way the AVG program only has to go to the DNS server to see if the AVG software and antivirus database updates are current, not back to AVG's servers. I had no idea it was possible to store anything in DNS records other than the name-to-IP information.

The problem happened because I recently upgraded to IPv4 + IPv6 dual stack ISP service. The cable modem and router being used is IPv6 capable and I've enabled both IPv4 and IPv6 in the Win7 networking panel. IPv6 has been working great at sites like ipv6.cnn.com and ipv6.google.com.

But it appears that IPv6 DNS records are not storing that additional program version information for AVG that the IPv4 DNS records did. Win7 will preferentially try IPv6 first and use that connection, then fail over to IPv4. The browser (firefox) works the same way and will use an IPv6 connection to a site preferentiallly first if available. So the error message happened with AVG update tried to get the version number info first from the IPv6 DNS servers, failed, then the OS tried again with the IPv4 servers and succeeded.

The solution to all this was to shut off the thing in AVG that tries to get the program version numbers from the DNS server records. Go to "Options" -> "Advanced Settings" -> "Update" and uncheck "Use DNS Update" under the "Additional update options" heading. This just forces the program to actually go back to AVG's own servers to check for updates, which is probably a good idea anyway so there is no a delay while that information propagates out to DNS servers.
My System SpecsSystem Spec