View Single Post
08 Feb 2013  
SheilaB

Windows 7 home premium SP 1 62-bit
 
 
System restore hangs on initialising / mouse not working

Hi, I have two problems.
It started when my mouse stopped working - wont move the cursor, altho right and left click work. Both wired and wireless, altho the wireless sometimes works if I switch it off then back on again, but not for long. Both types of mouse work on other computers in the house. Plugging into a different USB slot doesn't make a difference. Searched online for solutions. Uninstalled mouse in device manager. Cleared USB tree. Restarted computer which found mouse and reinstalled. Mouse still not working, altho properties say 'this device is working properly'. Still same problem. If I move the cursor with the touchpad I can click with the mouse.
So, I thought system restore might help, but it hangs on 'initialising' forever. Again, searched for solutions. Have done scandisk and scannow - reported back no problems. Volume shadow copy is set to manual - changed it to automatic but made no difference. Tried msconfig - hide all microsoft - disable the rest = no difference. Tried system restore in safe mode - still hangs.
Dell inspiron 5720
Installed memory (RAM) 6.00GB (5.86GB usable)
64-bit OS
Wiindows 7 home premium service pack 1
Thank you for reading.


Update
I think mouse problem is resolved. Wireless mouse - new battery. USB wired mouse now not recognised or working on other computer - think it's probably had it.
Still have system restore issue.
My System SpecsSystem Spec