View Single Post
04 Oct 2009  
sbear

Win 7 64-bit Enterprise Trial
 
 
64-bit Win7 can't handle 4 GB RAM without BSOD/reboots?

Hardware: See system specs.

I've put together a new clone system with the intent of running 64-bit Win 7 Pro on it. Until it becomes available, I have 32-bit XP Pro installed on it. Nothing is overclocked, in fact, the memory is "underclocked" for stability. I'd rather have it stable than gain some trivial performance improvement.

Previously, when I first built it up, I installed 64-bit Ubuntu "Jaunty" on it with 8 GB of RAM installed in it (4 X 2GB). The Linux distro installed and was perfectly stable.

To get a "heads up" on Win 7 issues, I downloaded and installed the trial Enterprise edition. Since I couldn't find any MD5 for the ISO, I downloaded the file twice and did a binary compare on the two downloads to ensure they were the same. Also, I see that the Java applet that downloads the ISO file also has some kind of "verify process" built-in that runs at the end of the download (a checksum?). I burned a DVD in XP Pro using Nero 8 with data verification on (after burning, it reads the burned disk and compares the disk's contents with the ISO file).

Since 32-bit XP Pro can't even fully use 4 GB, I uninstalled 4 of the 8 GB (two modules) when I installed XP on the box. When the entire 8 GB was in the MoBo, I ran MemTest86+ for long periods without errors. To do so, however, I had to "underclock" the memory to DDR2-800 speeds. It couldn't successfully run at DDR2-1066 speeds. A problem that, by checking various support BBS's, was found to be common with my MoBo and the RAM modules in question. After pulling the two modules, I left the memory timing at the conservative settings. I also let MemTest86+ run overnight and got no errors with the two modules installed. My plan is (or, was) to put the entire 8 GB of RAM back after I got 64-bit Win7 running on it.

When I installed XP, I left about 350 GB of the hard drive unpartitioned. I fired up the Win7 installer with the intent of installing it in some of the vacant space on the RAID array and dual-booting.

The installer ran until it finished loading files from the DVD and choked with the (apparently, usual) BSOD about the MoBo's ACPI implementation not being "fully compliant." I'm running the latest BIOS, and Gigabyte lists my MoBo as Win7 compatible.

I Googled the error and found that apparenly this nonsense has been going on since the early days of Vista and the answer was to get the installed RAM below about 3 GB. Sure enough, I pulled out one more module to drop the system to 2GB and the installer ran without a hitch. Apparently, removing RAM makes the MoBo's ACPI more compliant.

Also, in Googling around, I found suggestions that you install all the latest and greatest drivers for the various bit and pieces and then you can put your RAM back. Note also that I've left external devices (printers, scanner, etc.) off and/or disconnected to keep things at a minimum for now. So, I install Win7 drivers for the video card, sound, RAID controller and chipset. That's all I can find as the Gigabyte site and nVidia. Well, of course, the RAID controller driver actually got installed during the initial installation of Win7.

I configured the network connection, which up to now couldn't work since my LAN uses static IP's and doesn't run a DHCP server. Then, Windows update wants to install patches (not many) so I let it.

Well, that's all the updates and drivers I can install, so it's time to put the RAM back. I put back one module to bring the total to 4 GB and reboot. The system runs until there's just a hint of the four animated color deals that float around and become the Windows logo on a black screen. Just two tiny dots. Bam! The system reboots. Start it again and same result. Pull the 2nd module and drop back to 2 GB... the system boots just fine. I install a module and get the RAM back to 4 GB: it reboots at the same point. On the next attempt to boot it offers a "repair" boot as well as "normal." I pick "repair" just to see. I get the BSOD griping about my ACPI not being "compliant." I forgot that more RAM makes my MoBo's ACPI implementation less compliant.

Just to see, I knock the memory timing down to DDR2-667 speed. Won't boot. I put the timings back to DDR2-800 and bump up the North Bridge voltage a bit. Won't boot.

I don't have another video card to try. The old system I'm replacing used an AGP card and there's no AGP slot in the new MoBo. I've got some old ISA video cards, too, but I can't find a hammer to get them into any of the available slots.

I tried a "boot with logging," and let it rip until the reboot. Then, I pulled the 2nd module so that I could actually get it to boot and see the log. There isn't one. I searched the entire partition for "ntbtlog.txt" and there's nothing. I also tried searching for "ntbtl*.* and got nothing. So, apparently "boot with logging," didn't or at least died before it had the chance to save it.

There are no BIOS settings for ACPI except for the usual S1/S3 choice. This, of course, assumes the dubious concept that the root cause of this is actually the ACPI implementation of my MoBo, which I doubt.

So, anyone have any ideas? At this point, having seen how this has apparently been an issue for people since the RC versions of Vista with Microsoft and hardware manufacturers pointing fingers at each other, I suspect there is no answer. But I thought I'd see if anyone has any ideas before I decide that Win7 RTM really isn't ready for prime time. Even if I find some way around this, what's Microsoft going to do? Tell "grandma" to open the box and pull memory modules just to install Win7? Yeah, right.
My System SpecsSystem Spec