View Single Post
07 Feb 2009  
keshek

Windows 7
 
 
Crackling sound and audiodg.exe problems

Atm I am having 2 sound problems in Windows 7 x64. I am using a Soundblaster X-FI platinum PCI sound card. I am using the most recent Windows 7 beta drivers for my sound card, found here: Creative Worldwide Support

First problem is that often when multiple programs are using sound such as Media Player and a game and/or Ventrilo I get a slight crackle in the sound that slowly escalates. This gets worse and worse until the sound actually starts to lag and music even slows down and breaks up. At one point as this peaked I actually lost sound for about 30 - 45 seconds.

Second off the audiodg.exe process seems to have a serious memory leak. IT starts at about 11MB memory usage and atm, after about 2 hours of gaming and listening to music it is at 430MB.

I had to reboot about 2 hours ago do to memory usage problems. audiodg.exe was at about 300MB and it was about 1.5 to 2 hours since when I lost sound for about 30 - 45 seconds. I have 4GB of memory and from what I could tell looking at the task manager, I could only account for 2.5GB of the reported 3.5GB usage.

I have also read reports of random audiodg.exe cpu usage spiking. My theory atm is that after a while when the usage on audiodg.exe gets abnormally high, it starts to become unstable and eventually crashes. This would explain why I lost sound for 30 -45 seconds while windows restarted the process. I was not monitoring its memory usage prior to that so I cannot be sure. Also after the temporary loss of sound the crackling lessened and the sound lag went away. And since the reboot it has subsided for the moment, but it is a recurring problem I have had since installing windows 7.

Any input or ideas on how to solve the problem would be helpfull.
My System SpecsSystem Spec