View Single Post
17 Jan 2010  
richc46

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Quote   Quote: Originally Posted by Betta View Post
I was following the suggestion above for installing the XP driver and then fixing it for vista, except I have windows 7. I made it all the way through step 8. However, after I clicked on zUSB.inf and "open", I got the following error message and couldn't go any further:

"The folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with Windows for x64-based systems."

And then it goes back to asking me to browse to the location of the disk - I don't get an opportunity to click "OK", and the printer "HP LaserJet 1000" is not installed, working or not.

Any suggestions??

(The first time I tried to install this printer, the computer recognized it was an HP 1000. It took me to the HP site to try to download a driver, but there wasn't one. I talked to an HP technician, who told me that HP will not be developing a driver for this printer in Windows 7. Also, apparently there used to be a very basic driver available that would likely work, and he tried to help me get to a spot on HP's website to download it, only to find out that HP had updated its website and had removed that driver.)
Hi Betta,

This what you do. Make a sytem restore point. Then make sure you get rid of any driver remnants that may be present. Make sure the printer is not showing in devices and printers. Then go to the driver web site and pick the one that is for the closest edition of 7 that you can find. Then download to your documents folder. Then unplug the printer and turn it off. Now go to doucuments, right click on the driver, and click on xp or vista (as the case maybe for the driver that you have) compatibility mode. Then download. Turn on printer when asked to. Shut off your computer and boot up, it should be ready to print. If it does not work try a few times more. Sometimes this does not work at first, but eventually it usually does.
My System SpecsSystem Spec