View Single Post
22 Jan 2010  
CyberMax

Windows 7 x64
 
 
Wireless laptop connectivity

Cant really find a great way to describe my problem by topic alone.. but i have some weird problems with my 2 laptops running windows 7 x86.

Now.. My setup is basically like this:

Wireless router connected to my adsl modem from one of the LAN ports on the router (Basically working as a AP only.. No nat/firewall++)

I have 3 desktop computers connected to the lan ports on my adsl modem.

All computers get DHCP adresses from the ADSL modem, and are all set up to the same workgroup. I have tried the "homegroup" thingy, but that is only working until next reboot (as the laptop will be unavailable from the desktop computers).

All 3 desktop computers can connect/share files between them. I can ping all 3 desktop computers from eachother. I can ping all 3 desktop computers from my laptops. All 5 computers can connect to the internet without problems.

However, i can not connect from any of the desktop computers TO the laptops. Ive set up filesharing on the laptops, and i cannot connect directly from a desktop computer (wired) to the laptop (wireless). Now.. this would be easy if it was ONLY that.. but here is the twist :

I can access/ping/whatever TO the wireless computer if i FIRST connect FROM the wireless TO the desktop!

Meaning.. To access a share on the laptop, i first have to connect FROM the laptop to a share on my desktop.. and THEN i can access the laptop from my desktop just fine.

The same goes for normal ping.. Ie. if i ping the laptop FROM the desktop, i get request timeout. If i ping the desktop FROM the laptop first, and THEN ping the laptop FROM the desktop, it works fine.

I have ofc disabled firewall, i have NOD32 antivirus installed witch have no known firewall or filtering. (I also have tried disabling this).

Now.. this could be a basic wireless configuration setting on the AP itself, but if i boot the wireless laptop on eg. a ubuntu livecd, i can ping both ways with no restrictions at all!

Any ideas? Both the laptops are of different manufacturer.. one is a 2 year old Compaq pressario v6502EO, and the other is a brand new Acer Aspire.

C
My System SpecsSystem Spec