View Single Post
25 Jan 2010  

Win 7 x64 Pro
Transferring files from 7 to XP via SMB

Since upgrading my machine here at work to Windows 7, I encounter a strange issue with transferring files to a Windows XP box.
For instance, I use a robocopy script to mirror my files. If I run it under Win 7, I get sporadic errors for some of the files that look like:

"2010/01/25 14:32:15 ERROR 64 (0x00000040) Copying [...whatever]
The network path is no longer available"

Sometime, the connection seems to recover and the transfer continues until
the next ERROR 64 occurs.

Note that this also happens when I use Windows Explorer to copy files, I also
get sporadically "The network path is no longer available"-errors.

I tested the connection with NetIO (UDP-bench) to make sure, there are no packet
drops due to physical problems.

I also tried various "compatiblity"-tweaks like the one described here:
Samba network share issue with Windows 7
unfortunately, no luck.

Strangely enough, a "pull-based" approach works, that is: if the XP box
initiates the transfer, everything works just fine.

Does anybody have some more ideas concering this issue?
My System SpecsSystem Spec