View Single Post
09 Mar 2010  
Fdc

Windows 7 Home Premium 32-bits
 
 
System Restore points disappearing

System Restore points always disappearing at reboot! Help!

I keep getting the “volsnap” error messages in the Windows system event log during the early stage of the boot.
Error 09/03/2010 16:33:08 volsnap 25

The shadow copies of volume C: were deleted because the shadow copy storage could not grow in time. Consider reducing the IO load on the system or choose a shadow copy storage volume that is not being shadow copied.

Error 09/03/2010 16:34:04 volsnap 27

The shadow copies of volume C: were aborted during detection because a critical control file could not be opened.

I Installed Windows Seven 32-bits on a HP Pavilion dv6000 notebook 3 weeks ago, everything fine till I noticed that no restore point was kept longer than one day as of the beginning of my installation. I have 16 GB free on my system and set up the snapshot parameter max capacity to 9.3 GB which leaves plenty of space for the restore points.

Shadow Copy Storage association
For volume: (C\\?\Volume{f85119a2-15d8-11df-b8a7-806e6f6e6963}\
Shadow Copy Storage volume: (C\\?\Volume{f85119a2-15d8-11df-b8a7-806e6f6e6963}\
Used Shadow Copy Storage space: 81.594 MB (0%)
Allocated Shadow Copy Storage space: 448 MB (0%)
Maximum Shadow Copy Storage space: 9.316 GB (10%)

I did a clean install over windows XP with the Microsoft easy transfer tools and the Old Windows directory to setup the personal user profiles. My system is not dual booting. Just plain Windows 7 without raid and mirroring.

Application installed: Office XP with FrontPage, Office 2003 for Powerpoint Word and Excel, Adobe Creative suite v2.0, HP Quickplay, HP photosmart, Skype, Sonic DvdPlus, Google Earth and iTunes
Antivirus is “Microsoft Security Essentials”. No Norton products, CCleaner nor Spybot installed

The “create restore points” and the backup software is working without error messages.

My restore points are valid and working fine although not kept longer than one day. As well the manual ones as the window updates ones and the installation ones have been tested in a successful restore operation.

I am desperately at risk of loosing the system properties not being able to rollback after a system update or application installation. I tried everything, nothing helped.

Here are the things I tried out to cure the problem:

- Did the process with disable system protection, delete all the existing restore points, boot, re-enable the restore points, create a couple of them and test the reboot. No success.

- I deleted the “System Volume information” directory in case it got corrupted, playing around with ACL’s and ownership settings. No problem for win7, the directory was re-created, owned by system and when I re-enabled the system protection the restore points were again created without a flaw, but … deleted at next reboot.

- With Vssadmin I assigned the Max storage capacity (90GB) and even setting it to unbound. No success.

- I made a Clean-Boot disabling all services not belonging to windows and disabling all service start-ups. No success.

- I checked the disk c: with “Sfc /scannow” and “Chkdsk”. No errors detected.

- I did twice a complete Windows Seven upgrade/repair installation: one with only the minimum recommended safety settings and one with the complete recommended and safety settings. Still the same, no success.

Help me please, what can I do else ?
My System SpecsSystem Spec