View Single Post
18 Mar 2010  
Jerry120

Windows 7 Professional 64-bit
 
 
Slow internet

Quote   Quote: Originally Posted by richc46 View Post
Helen, I just cleaned installed 7 with IE 8 and everything is very fast. I think that you have a bad installation. Try this, take your original installation DVD, insert it into your machine and go through the process as though you are going to install. However, at the point that you are asked, indicate that you want to make a repair. Basically anything that is not working correctly will be changed. I think that you will be happy with the outcome. Once you are happy, install all of your programs and make a system image. Save it. If you ever have a problem you can use the system image to make your OS, just like it was when you were satisfied. Let me know how it works out.

Check to be sure that your computer has the proper specs for 7.
I have the same problem. Repair did not solve it. I have downloaded and installed the latest drivers for my Marvell Yukon Ethernet Controller, which helped slightly, but there is still a major problem. I ran speakeasy.com/speedtest and find that I'm getting about an order of magnitude slower download speed than I should. The ATT guys came out, made a number of changes including new lines, but nothing helped. They confirmed that I am getting full speed to the modem, and from the modem, using another computer, so I know my computer is the problem. My wife and I are on the same modem, when I unplug mine she is fine, when I plug in mine hers slows down. My motherboard has a unique feature; I can connect to the internet without loading the operating system. In that case, running speedtest, I get the full download rate, so the problem is not in my hardware, must be in my operating system. I don't know how to go any further. Please help.
My System SpecsSystem Spec