View Single Post
21 May 2010  
cbenedon

WIN 7 Home Premium
 
 
2329 error code

Not sure if this is pertinent, but check it out. SAME ERROR CODE.
Difference: I run 64 bit WIN 7.

SOLUTION:


The fix is to "upgrade" (which is actually REPAIR in WIN7). Sort of reinstalling. There is one other possible solution (uninstall SQL 2005) that you MIGHT be able to employ, but you should read the following;

It seems that SQL server 2005 is corrupt. I can't say for certain, but believe it happened with an update. I couldn't install updates, (or anything else, for that matter). The system couldn't even see it's own OS on the OS disc. I couldn't uninstall, either, which led me to believe is was the msiexec that was the culprit.

MS phone support logged onto my machine and got OFFICE running,(unreg/register) but it screwed up many other things that are connected to OFFICE, like my mail. Oh man! What a nightmare. I did EVERYTHING I knew. Spent a good 10 hours chasing this thing.

MS got on my machine again for 4 hours, couldn't fix it, put me up a level, MS called me the next morning (I must say here that their phone support was outstanding, even tho we wound up doing my initial suggestion, my theory was wrong)and we started back at it, again. TWO updates would not install. SQL 2005 SP and OFFICE 2007 SP. (service pack) You get the config.msi error because that is the rollback error code. After 2 more hours with MS on my machine with no fix, we agreed that an OS repair was in order. That wasn't so easy, as the I couldn't read the WIN 7 disc.

I thought the issue was with the MSIEXEC application. It is not. Since I couldn't read the original MS WIN 7 disc on either of my DVD drives, we thought the disc might be bad. I downloaded an iso to my desktop, created a DVD (which went quite easily and fast, but took 2 hours to download) and booted from disc. That didn't even work the first time, as it wanted me to start normally (seeing that it was already installed and anticipated an upgrade/repair) and then start with the disc setup.exe. But, I got the same error from the new disc that I had with the old one, that it couldn't read from the disc. I booted from disc again but this time, the system said "need to get an update to continue" or something like that, I clicked ok and it went online and installed the compatibility checker, checked the machine and came back telling me that the incompatible component was SQL 2005 and that it might not work after the install. I care? I continued and it installed/repaired the system and all is back to normal, running great.

Somehow the SQL app was corrupt. The other possible solution that I didn't try, but it won't hurt, is:

UNinstall SQL 2005 from the control panel, and see if that works. Had I known, in advance, I would have tried that. If that works for you, it will save you a LOT of time. The new install will reinstall sql2005, anyway.

Hope this helps.
My System SpecsSystem Spec