Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: No LAN connection after a system restore

07 Aug 2010   #1

Windows 7 Pro x64
No LAN connection after a system restore

Hi all,
I'm sorry if my English could seem poor.

I'm having big troubles with a strange misconfiguration in Win 7 Pro, 64 bit edition.

I had to make a disk recovery using the installation CD. This is not the problem, this work.

But once restored the system has reinstalled all the drivers. This has been worked too.

After this, when all seems to be restored i notice that I have no longer the LAN connection. And many services, starting with BFE, DHCP Client and more, crashed.

Read patiently, it's not one of the "common" issues.

First af all, the hw layer. Well, started a Linux Live CD the network card is ok. The led is green and flashes, so the network seems to work.

Windows however says that there are NO CONNECTIONs. If I open the control panel, in the network connection list... I can't find anything!!!! There are no the network connection. If i look at the "network control center" it tells me that the current connection is "unknown"

But there something more stranger.

If I open a terminal and type "ipconfig /all"... surprise!! MY LAN CONNECTION IS THERE. But it has wrong parameters (IP, Mask, so on) that let me think the system has lost the preceeding settings).

Well, so... when i open the control panel I can't see the connection, but the system recognize it. Let me try to set correct parameters via the netsh command line utility.

Well, this doen't work, because "The RPC service is not running".

Let's look at the services now.... I can't start BFE and any of the services that rely on it, because of an "Access Denied error"

Well, using the laptop i googled up and down, tried several steps, but nothing changed.

I tried to install reinstall the card drivers, but i don't feel the issue is related to drivers. I think is something misconfigured in windows

Does anyone know if there's a method to reinstall all the networking stuff without have to make a clean install of windows (and subsequently of all the software?)

I've omitted all obviously made checks... drivers, cable...

Any help would be appreciated.



My System SpecsSystem Spec
07 Aug 2010   #2

Windows 7 Ult, Windows 8.1 Pro,

Have you tried to run the recovery again?

Often times you need to run the recovery more than once in order to get everything working again. Running it three times will usually get everything back in order. You might want to clear your board first by shutting it down, unplugging the power cord and pushing the start button.
My System SpecsSystem Spec
07 Aug 2010   #3

Windows 7 Pro x64

Quote   Quote: Originally Posted by chev65 View Post
Have you tried to run the recovery again?
Oh, yes... I did.
First recovery run restored the disk partition . Second, from the restored partition itself, reinstalled the drivers .
But at the third attempt the recovery disk (the one from which the system was installed) has told me that can't repair my windows version beacuse can't recognize it. So I had to change way, without making myself too many questions....
My System SpecsSystem Spec


 No LAN connection after a system restore

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
System Restore Error, Unable to Create Restore Points
Hello everyone, not sure why but I get an error every time I open the System Restore. I rarely have to use a restore point as I regularly maintain my computer and check for viruses and malware, but I would like to have the option just in case. When I open System Properties, and click the System...
Backup and Restore
System restore doesn't show any restore points - but they exist
After Tuesday's Windows update I couldn't boot into Windows and loaded my system repair disk planning to roll back to a restore point from the day before. But, the restore wizard couldn't find any restore points. I know my system does it daily and I did a manual one a week prior just to see if it...
Backup and Restore
Allocated System Restore space holds far fewer restore points now
I have 8gb of space allocated to System Restore, all monitoring my C partition only. This space is always at least 85-90% used according to the System Protection screen. In the past I have had at least 15 restore points to choose from after ticking "show more restore points." But today I went to...
Backup and Restore
System Restore Has Stopped Automatically Creating Restore Points
My last automatically System Restore Point automatically created by the passage of time was created 2013-01-23. No further automatic system restore points are being created (that means not ever, not daily, not weekly, simply no longer created automatically by the passage of time since last...
Backup and Restore
Can System Restore Automatically Generate Daily Restore Point?
I used to be able to get a System Restore point generated daily and accessible on a calendar. I understand that the Restore Point calendar has been done away with, can't imagine why? Is it now possible to have a daily System Restore point automatically generated and easily accessible somewhere?...
Backup and Restore
System Restore - Restore system settings and previous versions of file
estore system settings and previous versions of file is greyed out on my system, I may have disabled a required service for this, can anyone point me to the right direction for this? As I'm about to try the X-Fi MB2 mod again as the last time I tried it my system was messed up that it wont even...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 21:47.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App