Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Update & System Restore Points BUG !?


01 Sep 2010   #1

W7-Enterprise + WS-2008 (Converted to Workstation)
 
 
Windows Update & System Restore Points BUG !?

hi !

2 days ago on 100830 (Aug 30) i restored my system to a System Restore Point created a few days earlier, on 100826 (Aug 26).

as i understand it, everything that has been installed AFTER the System Restore Point are then lost, including security-patches from Windows Update etc.

but when i yesterday realized that my system restore had removed the patch for KB2264107, (Windows6.1-KB2264107-x86.msu)
which i installed (manually) 100828 (Aug 28), i decided to install it again.

but to my BIG surprise the installer told me that it was: "already installed" !?
i started Windows Update, it reports all those updates installed AFTER the System Restore Point are STILL installed !?

i double-checked KB2264107, there is NO entry in the registry for that patch !
and of course there should not be any since i restored my system...

so the BIG question now is: why does Windows Update say that updates installed AFTER creation of the System Restore Point still are installed ?
fx. several updates from 100828 (Aug 28).

this must be a BUG ?

and System Restore still shows all System Restore Points created AFTER 100926 (Aug 26), should they not have been removed "automatically" ?

update:

i removed the "installed" (?) KB2264107, i then rebooted, ran the installer again & then checked the registy, there is still NO entry !?

i dont know what updates i REALLY have installed now, it looks like ill have to restore my System Backup, and start all over again with reinstalling the latest "Windows Updates"...

My System SpecsSystem Spec
.

01 Sep 2010   #2

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

I have found the same thing to be true. At that time, I felt that the update installer is not effected by the SR and it remembers that the update was installed. Unless it is a critical update, I would forget about it. In the near future SP1 will be here with all the updates and more.
My System SpecsSystem Spec
01 Sep 2010   #3

W7-Enterprise + WS-2008 (Converted to Workstation)
 
 

hi !

Quote   Quote: Originally Posted by richc46 View Post
I have found the same thing to be true. At that time, I felt that the update installer is not effected by the SR and it remembers that the update was installed. Unless it is a critical update, I would forget about it. In the near future SP1 will be here with all the updates and more.
thanks for confirming the "BUG".

it is an important update....
Windows6.1-KB2264107-x86.msu is the patch for: http://www.sevenforums.com/system-security/105488-critical-bug-40-different-windows-apps.html

and all the other security-updates since my restore point are also important...

but its not a big problem, i can restore my backup in 14 minutes, but then it takes some time (about an hour) reinstalling all updates.
My System SpecsSystem Spec
.


01 Sep 2010   #4

Microsoft Community Contributor Award Recipient

Windows 7 Home Premium SP1, clean install, upgrade disc
 
 

Look up the updates, again if not critical security, they can wait for the SP1.
My System SpecsSystem Spec
01 Sep 2010   #5

W7-Enterprise + WS-2008 (Converted to Workstation)
 
 

hi !

ALL of them are SECURITY-updates...

i have not installed any other updates, since i restored my system last time.
ive had some "weird" problems with OnlineArmor, got an errormessage about Miniport: "device driver not installed."

ive been working hard trying to find the cause, so i have installed only security-updates, 5 at a time.
i have then tried: reboot, hibernate & sleep.

i think i have found the cause among the last 4 updates, when i installed those last 4, i got the errormessage again.

so i restored to a point, and i installed only one of them, eveything worked normally,
so i decided to install another one instead, that was the reason for restoring to a system restore point.

but now that it seems impossible to have Windows Update show correct info about what has REALLY been installed and what remains to install, ill have to restore from my backup again.

anyway, i just wanted comments on the "BUG", good to see that im not alone having seen this BUG...
My System SpecsSystem Spec
Reply

 Windows Update & System Restore Points BUG !?




Thread Tools



Similar help and support threads for2: Windows Update & System Restore Points BUG !?
Thread Forum
Solved System Restore Has Stopped Automatically Creating Restore Points Backup and Restore
No system restore points after Windows wouldn't start Backup and Restore
Can I Pause/Turn off System Restore WITHOUT losing restore points? Backup and Restore
Viewing Windows System Restore Points Backup and Restore
Windows 7 System restore problem no restore points Backup and Restore
System Restore Points / Windows Updates Backup and Restore
no system restore points on windows 7 Customization

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:59 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33