Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows backup doesn't work?


11 Mar 2011   #1

Windows 7 Pro
 
 
Windows backup doesn't work?

I just tried running a backup on my Windows 7 Pro and got "backup application could not start due to internal error: Class not registered (0x80040154)"
I put a snip of it in (attachment) Why would that happen if I'm trying to set it up?



Attached Thumbnails
Windows backup doesn't work?-backup.jpg  
My System SpecsSystem Spec
.

02 Apr 2011   #2

Windows 7 Pro
 
 

Still looking for some help on this one. I really wanted to get that fixed before installing SP1. I thought installing the SP might fix what ailed it but it didn't.

I contacted support but they didn't get back to me, they sent me a request number but when I ran the diagnostic it said it couldn't send it.
My System SpecsSystem Spec
02 Apr 2011   #3

Microsoft Community Contributor Award Recipient

Windows 7 SP1, Home Premium, 64-bit
 
 

You can easily avoid Windows Backup and use free alternatives that are less confusing, less frustrating, and more flexible.

But you might have a particular reason to use Windows only?
My System SpecsSystem Spec
.


02 Apr 2011   #4
Microsoft MVP

64-bit Windows 8.1 Enterprise
 
 

Hello TC,

I agree that using a free backup program like Paragon Backup & Recovery 2011 (Advanced) Free instead is a good alternative.


If you really wanted to try and fix it, then....

You might see if running a sfc /scannow command may be able fix this for you.

If not, then as a test, create a new Administrator account and see if it works while logged in this new account instead.

If not, then you could try doing a system restore using a restore point dated before you started getting this error (if known or best guess)
My System SpecsSystem Spec
02 Apr 2011   #5
mjf

Windows 7x64 Home Premium SP1
 
 

This type of error can indicate a registry error. Problems with backup imaging may be a symptom not a cause.
Others may have a suggestion.
My System SpecsSystem Spec
03 Apr 2011   #6

Windows 7 Pro
 
 

Sorry I didn't get back to this. My weekend is totally out of hand.
I've run both SFC and the disk check, neither show any problem. I have also used Macrium reflect (the full paid version) and the free Acronis for western digital. I can't get either one to verify an image. I did try EASEUS Todo and it said I have a good image, I don't know if I can trust that. After a crash is no time to find out the software your using isn't trustworthy. That's why I was trying to use the one that came with my Windows 7 Pro. I thought there might be a compatibility problem somewhere.
I should also mention I had this same problem when I was running Vista on a different hard drive, same machine.
I've run stress test on processor and it passed. I've also checked both the internal hard drive and the external drive both pass (both are also new).

I tend to agree with mjf. Somewhere I have a file that isn't passing the checksum. That explains why they don't pass verification (meaning I have a good image). That doesn't explain why I get this " App can't start due to Internal error". What would be the internal error? Nothing is showing up in the event log and in my "services", the shadow copy is set to automatic and shows as running.
My System SpecsSystem Spec
Reply

 Windows backup doesn't work?




Thread Tools



Similar help and support threads for2: Windows backup doesn't work?
Thread Forum
Solved My bluetooth doesn't work. bttray doesn't open. Software
Backup and Restore Doesn't Work Backup and Restore
Control Panel Backup & Restore link doesn't work Backup and Restore
Net use doesn't work on Windows 7 computer Network & Sharing
Windows Installer doesn't work General Discussion
Solved HELP: power option doesn't work - screen saver doesn't start! General Discussion
Flash CS4 Doesn't work with Windows 7 x64 Software

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:39 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33