Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: system restore is always initializing


26 Mar 2011   #11

Microsoft Community Contributor Award Recipient

Win 7 Pro 64-bit
 
 

Try doing another system restore and make note of the time you start and the time it fails. Then check the Event Viewer log (it might take about 15 minutes or so for the data to appear in the log) for any errors that appear between the start and fail times. Post the info here and perhaps we can help figure out what's happening.

If you'd rather not wait, and if you have a full install disk for your OS (an OEM recovery type disk from a manufacturer won't work nor will a set of disks created by you from a recovery partition) you could try a Repair Install. Personal data like photos and documents won't be affected. Personally, I'd wait to see what the Event Viewer log shows.

Repair Install


My System SpecsSystem Spec
.

26 Mar 2011   #12

Windows 7 Ultimate x64
 
 

the problem there is it does not fail on its own i have to reset the pc no matter how long i leave it restoring and all the event log says is:

System restore ended unexpectedly because of power loss or a program error.

and as for a repair install i cant do that because the company i got my pc from did not send me a disk and have went bankrupt so i cant ask them for a disk.
My System SpecsSystem Spec
26 Mar 2011   #13
Microsoft MVP

W 7 64-bit Ultimate
 
 

Quote   Quote: Originally Posted by Baz162 View Post


and as for a repair install i cant do that because the company i got my pc from did not send me a disk and have went bankrupt so i cant ask them for a disk.

Do you have a friend with an exact version installation DVD or you could find a download, have a look at this tutorial at the link below; though it is against forum rules to post d'l links.

Windows 7 Universal Installation Disc - Create
My System SpecsSystem Spec
.


12 Feb 2012   #14

Windows 7 Home Premium 64 bit
 
 

I had this exact same problem and none of the solutions found online worked. What finally worked for me was this:

I had more than one hard drive with System Restore activated.
I turned off System Restore for all but my main drive (drive C, the one with Windows 7).
System Restore now works.

Initializing still seems to take a while (about 3 - 5 minutes) but now it eventually does perform the Restore action.

Hope this helps somebody.
My System SpecsSystem Spec
28 Jul 2012   #15

Windows 7 Home Premium 64bit
 
 
No Luck

Turning off all of the System restores from all but the main Windows partition did not fix this problem for me. I have two partitions, a recovery and a Windows one. The recovery was never on to begin with. I did activate the recovery drive and then turned it off
My System SpecsSystem Spec
08 Mar 2013   #16

Windows 7 Ultimate x64
 
 

I ran system restore in safe mode, seemed to have worked that way.
My System SpecsSystem Spec
Reply

 system restore is always initializing




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 03:25 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33