Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System Restore Not Working

20 Jun 2011   #1
Buckalou

Windows 7 x64
 
 
System Restore Not Working

Hey everyone I am having a very difficult and annoying problem to fix. First it started out I wasn't able to do a system restore to an earlier time running windows regularly but in safe mode. Now I can not do a system restore in safe mode or running in normal mode. When I try to run the restore to an earlier point it will restart say system restore is initializing, say it is complete and boot up and then say System restore did not complete successfully and none of my files were changed. I have tried everything from disabling AVG antivirus to running in safe mode and researching the problem in debth, but I can not figure out what to do. This happens on every single restore point. I went into the event viewer and found the following errors:
1. Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80004002, No such interface supported. (Event ID 8193)
2. Volume Shadow Copy Service error: A critical component required by the Volume Shadow Copy service is not registered. This might happened if an error occurred during Windows setup or during installation of a Shadow Copy provider. The error returned from CoCreateInstance on class with CLSID {4e14fba2-2e22-11d1-9964-00c04fbbb345} and Name CEventSystem is [0x80004002, No such interface supported]. (Event ID 22)
3.
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80004002, No such interface supported.
Operation:
PrepareForBackup event
Executing Asynchronous Operation
Context:
Execution Context: Requestor
Current State: PrepareForBackup (Event ID 8193)
4.
Volume Shadow Copy Service error: Unexpected error calling routine CoCreateInstance. hr = 0x80040154, Class not registered.
Operation:
Gathering Writer Data
Executing Asynchronous Operation
Context:
Execution Context: Requestor
Current State: GatherWriterMetadata (event ID 8193)
5. An unspecified error occurred during System Restore: (Windows Update). Additional information: 0x80070057. (Event ID 8210)
6. Failed to create restore point (Process = C:\Windows\servicing\TrustedInstaller.exe; Description = Windows Modules Installer; Error = 0x80042302). (event ID 8193)
Please help, I have did sfc scannow and nothing came up, scanned for viruses, malware, etc and nothing came up. I am really lost so if any of you could give your input it would be greatly appreciated.

Thank you very much!


My System SpecsSystem Spec
.

20 Jun 2011   #2
rbeldua

MS Windows 8
 
 

to get you started while we wait for others for better recommendation.

here's an article about the shadow copy provider had an unexpected error.

The shadow copy provider had an unexpected error | Online IT Support
My System SpecsSystem Spec
20 Jun 2011   #3
Buckalou

Windows 7 x64
 
 

I will try this thank you. Can entering those commands do any damage or harm to my computer at or? Or is there a risk of anything occuring?
My System SpecsSystem Spec
.


20 Jun 2011   #4
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Why did you need to use System Restore?

Have you tried System Restore from a Startup Repair CD:
System Repair Disc - Create

System Recovery Options
My System SpecsSystem Spec
20 Jun 2011   #5
Buckalou

Windows 7 x64
 
 

I used it because I installed a program and it made some registry changed and system changes that I did not like. I have not yet tried it from the disc as I do not have one made currently. Should I make one and then try it from that? If I do that thouhg it won't have any previous versions or restore points on it though correct?
My System SpecsSystem Spec
20 Jun 2011   #6
theog

Microsoft Community Contributor Award Recipient

ME/XP/Vista/Win7
 
 

Running System Restore from CD can find more Restore points, so it may find a good one.

Have you uninstalled the App.
My System SpecsSystem Spec
20 Jun 2011   #7
Bare Foot Kid
Microsoft MVP

W 7 64-bit Ultimate
 
 

You may also find this method of doing an sfc /scan useful, you will need the created repair disk for this also and be sure to post back with any further questions you may have and to keep us informed.

SFC /SCANNOW : Run in Command Prompt at Boot
My System SpecsSystem Spec
20 Jun 2011   #8
Buckalou

Windows 7 x64
 
 

yes I uninstalled the program, so I made a disc should I try to restore from that disc or repair files or both? Bare Foot Kid I ran SFC / scannow and no errors came up.
My System SpecsSystem Spec
20 Jun 2011   #9
Buckalou

Windows 7 x64
 
 

How do I run the system repair disc once I have it created?
My System SpecsSystem Spec
20 Jun 2011   #10
SIW2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Here is an app. you can run from within windows : Attachment 160744 and no, it won't do any harm
My System SpecsSystem Spec
Reply

 System Restore Not Working




Thread Tools





Similar help and support threads
Thread Forum
System Working fine but reboots to system restore
Hello, I will try to explain this as best as I can so if you need any more information please ask and I will gladly answer. If this is in the wrong forum I apologize. If it is please redirect me and I will post it there. I have built 11 computers, all containing the EXACT same hardware and...
Installation & Setup
System restore not working
Hi. I am having a problem getting my SYSTEM RESTORE to save my restore points. It was working fine, but now refuses to work! When I attempt to save a restore point I get an error message as follows. 0x81000203. Can anyone who has had this problem and sorted it please give me the benefit of...
Backup and Restore
system restore not working
i opened system restore.error occured.no restore points.please help.see attached file
Backup and Restore
System restore not working
This is a two part question. It started a few days ago after Firefox did an update. The next day I noticed that when I entered a search request in the address bar of Firexox it used Yahoo to run the search instead of Google which I had set as my default. I hate Yahoo with a passion.:mad: Anyway...
Backup and Restore
System Restore not Working
I recently ran a Registry cleaner and being a Newbie have done something to my registry. I cannot systems restore it just says %systemroot%registration Destination: ComPlus Staging Is there anyway to rectify this. Liz
Backup and Restore
Backup and restore (Not System Restore) Not Working
When I try to back up and restore (my files) it does not complete. I get the message disk full. I tried to uncheck the (shut off and delte all files from system restore) but that does not help. When I check the amount of space available on the D drive, it shows as full, but system restore seems to...
Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:20.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App