Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Custom PE Image

25 Aug 2009   #1

Windows 7
 
 
Custom PE Image

I am trying to import a custom PE image into SCCM but I got a problem, SCCM requires the image to be "finalized". I have found tons of documentation of how to do it using peimg.exe the problem being that WAIK for Win 7 doesn't have peimg instead uses DISM for most everything. Anyone have any idea how I can finalize a boot image in the new WAIK? Any help would be appreciated.


My System SpecsSystem Spec
.

25 Aug 2009   #2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

peimg.exe /prep C:\temp\winpe_amd64\mount /f
My System SpecsSystem Spec
25 Aug 2009   #3

Windows 7
 
 

Ok this might be my issue, I don't have peimg.exe in my waik folder (or any subfolders). I just assumed that it was now a DISM command.
My System SpecsSystem Spec
.


25 Aug 2009   #4

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

New Features in the Windows AIK

Quote:
PEimg.exe. PEimg.exe is the command-line tool for creating and modifying Windows PE images. The functionality of this tool is included as part of the DISM tools.
Sounds like it is a DISM command - you just issue the peimg.exe /prep command even tho. you can't see peimg as a separate tool.

Did you try it?

I haven't done it myself - so please keep us posted of anything you find.
My System SpecsSystem Spec
25 Aug 2009   #5

Windows 7
 
 

I think I already tried just running it and got an error, I will try again tomorrow just in case. I don't remember the error I got so it might have just been syntax, who knows. Thanks a bunch, I will post the outcome tomorrow.
My System SpecsSystem Spec
25 Aug 2009   #6

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

My System SpecsSystem Spec
26 Aug 2009   #7

Windows 7
 
 

Ok so instead of dealing with possible errors from my previous attempts I did a cleanup and deleted all associated folders and started clean. I got to the finalization step with only a few hiccups (couple errors in my driver install and for the life of me I can't find trace32 on my LM or server).

I ran:
peimg.exe c:\temp\winpe_x86\mount /f

and I got the following error:
'peimg.exe' is not recognized as an internal or external command, operable program or batch file.

Any ideas?

PS. Thanks for that link, sped things along much quicker this time, though I still got an error in the process.
My System SpecsSystem Spec
01 Sep 2009   #8

Windows 7
 
 

Still wondering if anyone has any clue why I can't run peimg?
My System SpecsSystem Spec
Reply

 Custom PE Image




Thread Tools



Similar help and support threads for2: Custom PE Image
Thread Forum
How to Create Custom Start Orb Image Tutorials
Looking to hire someone to create custom OEM deployment image General Discussion
Most Advanced Custom Image? Installation & Setup
Custom Taylor Master Image General Discussion
Easy Custom image + custom recovery OEM like system? Backup and Restore
Custom Explorer Background Image Customization
Deploying Windows 7 Custom Image - Fails Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:02 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33