Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Both Windows Backup and System Restore not working


27 Sep 2012   #1

Windows 7 Home Premium 64
 
 
Both Windows Backup and System Restore not working

Windows backup says it is running but it really isn't. System restore has quit working too. I can't restore to an earlier date. Anyone have a suggestion as to what I could try? I have Win 7 Premium 64 bit.

Thanks

My System SpecsSystem Spec
.

Reply

 Both Windows Backup and System Restore not working




Thread Tools



Similar help and support threads for2: Both Windows Backup and System Restore not working
Thread Forum
System Restore / Backup not working Backup and Restore
Solved Complete System Restore from Windows Backup did not fix computer Backup and Restore
Backup, System Restore, Trim, On Windows 7 SSD Backup and Restore
New SSD System Restore and Windows Backup Backup and Restore
Windows 7 backup and restore has stopped working Backup and Restore
Image Backup and System restore stopped working? Backup and Restore
Backup and restore (Not System Restore) Not Working Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:29 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33