Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Help Please! Can't do system restore


23 Sep 2009   #1

w7 x64
 
 
Help Please! Can't do system restore

My computer was fine until i install the Advanced system optimizer v3. Now my system give me a bsod on startup. I tried startup repair , but it couldn't fix it, so I try to do a system restore. After I chose the most recent time to restore, which is when I installed the damn ASO, I click next. The next screen asked me to check the drive that contain windows to restore, for some reason I can't check it. There is only one drive which is the "Local Disk (C (system)" on the status tab I see this message "You must enable System Protection on this drive" I don't think I ever disable it, or else I wouldn't have the restore points right? It wouldn't let me tick the check box on the C: drive. I have no idea what I should do next. Please help me. I'm on Windows 7 x64. I also tried the Last know good configuration, but it also gives me bsod, I tried to boot in safe mode, it also give me bsod.

My System SpecsSystem Spec
.

Reply

 Help Please! Can't do system restore




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 01:38 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33