Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System Restore does not work


04 Jan 2013   #1

Windows 7 Ultimate x64
 
 
System Restore does not work

Hi,

it seems that either trojan or MBAM deleted some Windows 7 x64 (see my system specs) System files on my PC.
Upon checking Windows Update, I was notified that the service is not running. In addition, Windows Security Center Service was turned off and couldn't have been turned on.
I spent a couple of days Googling for solutions and finally succeeded in restoring BITS and WSCS in Services. After that, downloading updates was enabled, but installing could not be performed, because System Restore does not work.
I turned off system protection and now I can download and install updates in small increments. I can't install all 300 MB of updates at once (there were 53 of them). OK, eventually I will install them all, but I would like to enable System restore.
I must stress that restore point can be made, but restoring can not be performed.
I tried to start System Restore Service but to no avail: "Windows could not start the System Restore Service on Local Computer. Error 126: the specified module could not be found"

Besides, when I reboot, I got message: "Error in srclient.dll. Missing entry CreateFirstRunRP"

Since sr.inf file was missing (along with some other system files), I copy/pasted it from another computer with the same OS. I tried to install sr.inf, but I was asked for other files (sr.sys, srsvc.dll, srrstr.dll, filelist.xml, rstrui.exe, srdiag.exe, srframe.mmf...) which were missing. Then I copied those files from the same computer, as well, but to no avail, since sr.sys could not be found neither there nor on installation disk.
(btw, I have Avast AV) I performed sfc several times in a row, but it found nothing. MBAM also found nothing.
This problem could be solved by reinstalling Windows, but I would like to avoid that, if possible.

Any advice as to how to make System Restore work?

My System SpecsSystem Spec
.

04 Jan 2013   #2

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Welcome to sevenforums steampunk7,
try a sfc scan to start with...

SFC /SCANNOW Command - System File Checker
My System SpecsSystem Spec
04 Jan 2013   #3

Windows 7 Ultimate x64
 
 

Thanx for the advice. But, I already said in the post that I performed sfc scan several times in a row.
My System SpecsSystem Spec
.


04 Jan 2013   #4

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

Ah! sorry, i missed that.
you could consider a repair install,
though wait until you get some more responses to your thread.

Repair Install
My System SpecsSystem Spec
04 Jan 2013   #5

Windows 7 Ultimate x64
 
 

I'll wait
My System SpecsSystem Spec
07 Jan 2013   #6

Windows 7 Home Premium 32 bit
 
 

A repair install should definitely help restore your OS.

But before that you can try Reenable II Lite edition Downloads

(Only the Lite Edition can work with Windows 7 64bit. If your OS is 32bit you may use the portable edition. Just to know more about the software Download Re-Enable Portable 2.0.1.0 Free - Allows you to quickly repair damaged system registry keys. - Softpedia )

Name:  08-01-2013 09-23-19.jpg
Views: 12
Size:  57.1 KB


My System SpecsSystem Spec
08 Jan 2013   #7

Windows 7 Ultimate x64
 
 

Reenable II Lite didn't solve the problem. Thanx for trying to help, anyway...
Btw, I read carefully "How to Do a Repair Install to Fix Windows 7" link and it seems that it actually guides you through re-installing Windows...?
My System SpecsSystem Spec
10 Jan 2013   #8

Windows 7 Ultimate x64
 
 

I had read through a number of threads in the meanwhile. Upon reading this one ...
(scroll down to "Debleena S replied on October 30 2009)
Windows Modules Installer Error:126 - Microsoft Community
...I tried to re-register Windows Update DLLs but I ran into some problems there:
"The module "wuaueng1.dll" failed to load.
Make sure the binary is stored at the specified path or
debug to check for problems with the binary or
dependant .DLL files.
The specified module could not be found."

I got the same error message for the following two dlls:
WUWEB.DLL
WUCLTUI.DLL

Can this be fixed by copying those three dlls from another system ?
My System SpecsSystem Spec
18 Jan 2013   #9

Windows 7 Ultimate x64
 
 

I finally succeeded to fix both Windows Update and Windows Firewall (which was also disabled), by following advice of Bron here and Narenxp here.
After the BITS, WSCS and Volume Shadow Copies services were restored, I was able to download and install Win Updates, but System Restore still does not work:
"SR did not complete successfully...etc...An unspecified error occurred during System Restore. (0x80071a90) "
I must stress that restore point can be made, but restoring can not be performed.
I tried to start System Restore in Services but to no avail: "Windows could not start the System Restore Service on Local Computer. Error 126: the specified module could not be found"

Besides, when I reboot, I got message: "Error in srclient.dll. Missing entry CreateFirstRunRP"

I tried to reinstall SR using the command line:
rundll32.exe advpack.dll,LaunchINFSection %Windir%\Inf\sr.inf

but I couldn't do that, since it seems that several files were missing: sr.inf, sr.sys, srsvc.dll, srrstr.dll, filelist.xml, rstrui.exe, srdiag.exe, srframe.mmf...
My System SpecsSystem Spec
Reply

 System Restore does not work




Thread Tools



Similar help and support threads for2: System Restore does not work
Thread Forum
Solved System restore from a USB stick does not work Backup and Restore
Dell XPS Crashes .System repair,system restore ,safe mode don't work BSOD Help and Support
System restore wont work. Backup and Restore
I cant get System Restore to work. Backup and Restore
system restore does not work Backup and Restore
System Restore will not Work. Backup and Restore
System Restore Does not work - Norton Backup and Restore

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:24 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33