Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Cloned HP_Recovery partition wont boot

24 Dec 2013   #1

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 
Cloned HP_Recovery partition wont boot

OK, this time I am going to cut this really short..no explanations as to why i am doing this. I just typed a detailed post, clicked Submit New Thread..and it said i was not logged in and I lost the lots.

I want to replace the original HDD with another
I Cloned the original HDD; Cloned the 3 partitions (System/HP Recovery, HP Tools) and created a blank Win partition for HP _Recovery to restore too.

I did this by using a Win PE Live boot USB and ImageX to create wim files, then ImageX again to Apply the wim images to the new HDD.

Cant create HP recovery CD's from within Win 7..the 4530 does not ship with the Recovery creation software.


I used these instructions' here: Need help with HP recovery partition on new hard drive - Systems

Trouble is, when I get to rebooting with new HDD and hitting F11 either F11 does to appear ..or if I can get it to appear by using either EasyBCD, it then does not boot to the recovery partition.
tried Setting the partition as active
tried various bootrec repair or rebuild options.
Tried booting from Win 7 install DVD and using repair. That does not work either.

Anyone got any clues as to what to try?

Please don't say Google..that is all I have been doing for two weeks and not come up with a solution yet.

My System SpecsSystem Spec
.

24 Dec 2013   #2

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

What is on the recovery partition?

You need to add the bootable wim file to bcd. It is probably called boot.wim. (Might be called winre.wim )

It may be in a folder on the recov partition, "sources" folder is likely.

You can do it with easybcd, use the WINPE tab and browse to boot.wim on the recov partition.

That should give you an entry on the boot menu. When you have done that, we can have a look at assigning a scancode (e.g. f11)
My System SpecsSystem Spec
24 Dec 2013   #3

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

The original HP_Recovery partition does not seem to have a wim file.
Edit: Yes it did, I had not changed Win Explorer to show Hidden & Sys files. .. Doh


I have just booted in to Win PE again, cleaned the target HDD and am using the imageX tool to restore the partitions to the target drive
I'll get back to you on exact HP_REcovery contents when restored again.
My System SpecsSystem Spec
.


24 Dec 2013   #4

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

How are they doing a recovery without using a bootable wim? Maybe boot.wim is a hidden system file, or they are using the winre.wim in the hidden recovery folder - probably in C:\recovery\long_number

eg here is a pic of sony recov, there is the hidden boot.wim file. That loads into ram and extracts the image from the install.swm files.

The bcd entry needs to point at the bootable wim

Name:  sonyrecpart.jpg
Views: 43
Size:  172.9 KB


My System SpecsSystem Spec
24 Dec 2013   #5

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

Here is a couple of screen shots.
Disk manger Disk 0 is original, Disk 2 the clone

In the explorer windows Original on LHS, clone on RHS.

I did find a hprecovery.wim file within the folder structure, and am attempting to use ImageX to recover it to the clone Windows partition..so it is another way..if it works..

ut it still does not solve the original issue of why the F11 does not work, although the recovery partition is identical


Attached Thumbnails
Cloned HP_Recovery partition wont boot-dsk-mng.jpg   Cloned HP_Recovery partition wont boot-exp1.jpg   Cloned HP_Recovery partition wont boot-exp2.jpg  
My System SpecsSystem Spec
24 Dec 2013   #6

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

looks like we cross posted.
..got about 3 minutes to go on the restore of the discovered wim file within the structure.
Maybe restoring that will then sort the F11 issue if future recovery required.
My System SpecsSystem Spec
24 Dec 2013   #7

Microsoft Community Contributor Award Recipient

Vista x64 / 7 X64
 
 

Yes,it might. Let us know how it goes.
My System SpecsSystem Spec
24 Dec 2013   #8

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

ImageX restored that hidden hp-recovery.wim file, but it still dos not boot from the 'new c:\"

Just booted from Win 7 install disk and that has completed a successful repair of the SystemPartitionTable'

it is now booting in to what looks very much like the initial factory first start..instaling drivers etc etc.

BUT..that still does not explain why the F11 boot did not work....but maybe once the OS is installed correctly on the C:\...F11 may then work again correctly?

May not attempt to find out until after tomorrow..I have a feeling I am supposed to be doing something tomorrow not PC related....you know..interacting with humans rather than threatening physical violence against inanimate objects.

Thanks for the help..it may not be over yet.

Oh..the reason i am transferring the original OS partitions to a smaller drive is that i want to use the original 650gb HDD in a CD caddy HDD holder. the main slot being used to house a SSD running OS-X
These 4530's machines are almost perfect for running mac OS-..with a few tonymac tweaks. but i don't want to loose the ability of going back to Windows 7...but don't ahve the money for any new kit at moment..not worked since August
My System SpecsSystem Spec
24 Dec 2013   #9

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

umminteresting..


restored and booted..but with none of the HP apps and lots of devices in Device manager not working.
My System SpecsSystem Spec
24 Dec 2013   #10

Many: XP, 7, Home & Pro, Slax, FreeNAS, OS-X 10.9 10.6.8
 
 

The first re start after the restore give a Warnng message that Windows Could not set up devices for this hardware...
Then a few mins later
Windows Could not complete the instalation. To install Windows on this computer restart the instalation...
My System SpecsSystem Spec
Reply

 Cloned HP_Recovery partition wont boot




Thread Tools



Similar help and support threads for2: Cloned HP_Recovery partition wont boot
Thread Forum
Need Help. W7 wont boot after resizing partition. Recovery wont work. Installation & Setup
Win 7 cloned drive wont boot Backup and Restore
Solved Need help re using D:(HP_RECOVERY) partition for my data Backup and Restore
How to keep HP_RECOVERY partition when deploying with WAIK Installation & Setup
Repair/Recover HP_RECOVERY Partition Installation & Setup

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 02:52 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33