Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: VHD created and attached, but not showing up in Computer Mgmt Window

18 Sep 2014   #1
vpombo

Windows 7 32 bits
 
 
VHD created and attached, but not showing up in Computer Mgmt Window

Hello there,

Your help please!!

I created and attached a vhd, but is not showing up in Computer Management window, under Disk Management.

I need to access the vhd to copy some information.

Your help is very much appreciated

Cheers

VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-1.png

VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-2.png




My System SpecsSystem Spec
.
18 Sep 2014   #2
mjf

Windows 7x64 Home Premium SP1
 
 

When you attach the vhd there is a default read only option which is selected as default. I have found you often need to deselect this option. I'd prefer to leave it read only but you get what you are experiencing. As long as you don't write to the mounted vhd you shouldn't have any problems with a subsequent system image restore.
My System SpecsSystem Spec
19 Sep 2014   #3
vpombo

Windows 7 32 bits
 
 

Thanks mjf.

I made sure to attach the vhd file without the "read only" option, using both Disk Management and VhdAttach.

Same results. Can't see the virtual drive in either Computer Management window or Windows Explorer.

What else could I try?

Again, thanks a lot for the help.


Attached Thumbnails
VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-3.png   VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-4.png  
My System SpecsSystem Spec
.

19 Sep 2014   #4
mjf

Windows 7x64 Home Premium SP1
 
 

I'm not sure what's going on. Try following the steps in this tutorial in case you've missed something.
System Image - Extract Files Using Disk Management

I haven't had a problem with Windows inbuilt for basic imaging or mounting its vhd files but others have. So you may want to try (free) Macrium Reflect in future. It's reliable and very easy to mount the images to copy out files/folders if you need.
My System SpecsSystem Spec
19 Sep 2014   #5
vpombo

Windows 7 32 bits
 
 

Thanks for trying to help me mjf.

Installed Macrium, trial version.

After attaching the vhd file, at least Macrium detects there is a virtual drive. But under details panel on the left hand side says

File System: Empty
Free Space: 97.56 GB
Total Size: 95.56 GB

How come it is empty. Windows Explorer says the file is about 45 GB in size.

It seems that the file contains data, but why I cannot read it?

Thanks again.


Attached Thumbnails
VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-5.png   VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-6.png   VHD created and attached, but not showing up in Computer Mgmt Window-vhd-not-showing-up-7.png  
My System SpecsSystem Spec
19 Sep 2014   #6
mjf

Windows 7x64 Home Premium SP1
 
 

I didn't expect Macrium to help in your current situation. I'm suggesting that the free version of Macrium may be a better imaging alternative in future.
Macrium Reflect FREE Edition - Information and download

It's looking like your current vhd file may be corrupt. You could try renaming your existing WindowsImageBackup folder then create a new image using Windows inbuilt imaging. Then attempt to attach the new vhd. If this succeeds then its looking like your old vhd is corrupt. Here is the tutorial that discusses renaming
Backup Complete Computer - Create an Image Backup

I'll ask if others have any suggestions.
My System SpecsSystem Spec
19 Sep 2014   #7
vpombo

Windows 7 32 bits
 
 

Thanks again mjf.

I'll have to try this later because I have got urgent work and family matters to attend to. I hope to do this within the next two weeks.

I'll keep you posted on the outcome of the process, so you can learn from my experience.

Again, many thanks
My System SpecsSystem Spec
Reply

 VHD created and attached, but not showing up in Computer Mgmt Window




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Icons showing up as grey squares; like little pages (image attached)
About a week ago most of the icons on my computer started showing up as if a small grey page icon were placed over them. Please see attachment. I thought perhaps this was a virus and ran Microsoft Security Essentials, Spybot S&D, and Malwarebytes but nothing was found. I have tried going...
General Discussion
Printer attached to W7 computer will not share with XP computer
Before going into the details, I have used this setup (W7's printer accessed from XP) for months. I'm now using another XP computer and can't get it to work - although it can "see" the printer via the workgroup and tried to connect to it, it can't find a driver (of which more later). So it may well...
Network & Sharing
BSOD twice in three days now showing MTXPSERD.dll -Minidump attached
Got a workstation running Windows 7 Professiona, 64 bit. Has randomly BSOD twice now in three days. On the BSOD states something about MTXSPERD.dll. Have attached Minidump so any help would be really appreiciated.
BSOD Help and Support
appointments not showing up after created outlook 2010.
Hello. When I create a calendar event in outlook 2010 it does not show up in day/week/work week/month view, however it sometimes syncs with my hd2 and shows up as an appointment on the pocket pc screen. If I try to create another event over the same time period while using my desktop, it...
Microsoft Office
Too many Partitions created on new computer
Whist setting up my new Fujitsu AH530 laptop, a box appeared asking whether I wanted to partition the hard drive. This being the second laptop running Windows 7 and a prior one running Vista, that I have started from new, I know that, being Dual Core, there will be two partitions as standard (C&D)....
Installation & Setup
Created folder only showing up in DOS environment
To Whom it May Concern, I am attempting to write a batch file and I have run into several issues with the WIN7 command interpreter. But this one has me completely baffled. In testing my batch file, I typed the command at the cmd line. This is my command: Start /wait /b Robocopy...
General Discussion


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 15:13.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App