Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Robocopying an entire share from server to server gets error 2

22 Sep 2014   #1
vanastr

64
 
 
Robocopying an entire share from server to server gets error 2

I've run into an issue several times when trying to copy an entire share from one server to another. In this case, it happens to be from a Mac to a Windows server (just in case that's relative to the problem). The command I was using is:

robocopy \\MacDASD\Boards \\SRVRWIN78\Boards /S /FFT /XJ /R:1 /W:5 /V /TS /TEE /L

This runs fine, showing all the files and subfolders from the Mac's 'Boards' share that would have been copied. However, once the '/L' is removed to actually run the command I get 'ERROR 2 (0x00000002) Accessing Source Directory \\MacDASD\Boards. Running Robocopy for each of the subfolders under the 'Boards' share, however, works fine. It seems it just can't do the entire share at once. Any help would be appreciated.


My System SpecsSystem Spec
.
22 Sep 2014   #2
Tookeri

Windows 7 Pro 32
 
 

A quick search indicates error 2 could be:
- Some Extra files or directories were detected. Examine the output log.
- The system cannot find the file specified.

You could try to increase the retry parameter from /R:1 to a higher value.

I also found this but I don't know if it's correct or not, nor if error, exit codes and errorlevel are equal values:
Note also that bit 0x02 simply indicates that there are files at the destination that are not present at the source. This will happen if the /E switch is used and files have been deleted from the source since a previous copy was taken. It should not happen if the /MIR switch is used because that should delete files at the destination to mirror the source (but I haven't tested this).
Getting ROBOCOPY to return a "proper" exit code? - Super User
My System SpecsSystem Spec
17 Sep 2015   #3
joe1981al

Windows 7 Pro 64bi
 
 

I received the same issue and could not find the solution. It turns out that the default for /DCOPY is /DCOPY:DA which tries to read NTFS Stream data, and it seems that the Mac or other linux based Samba shares will not respond nicely when robocopy request that data on the root of the share. By doing /DCOPY:AT, this is avoided and the copy should go successfully.

Just wanted to share this since I was having the exact same problem when trying to copy from a Synology NAS with RoboCopy.
My System SpecsSystem Spec
.

Reply

 Robocopying an entire share from server to server gets error 2




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
Win 7 Pro File Server, want to share folders with different passwords
Hello to all, I've looked high and low for an answer to my question and I'm here now due to not finding answers via Google. We're in a small office environment and we have a new Win 7 Pro computer acting as a file server. There is a Z drive mapped to all office computers with all general...
Network & Sharing
how can I bring back a server-share to a win8-notebook?
i have a new win8-notebook connected to a workgroup-ethernet-network via router,to which a windows -server is connected and 6 other clients,2 of them macs,4 xp-pcs. on all machines,3 other machines resp shares are constantly visible in "network places": 1 the server-share 2 a client-1 share...
Network & Sharing
How to share server's internet connection to VPN?
Hi, I am using a VPN connection from my Android phone to my home PC by using the "default" Windows 7 (Ultimate x64) VPN feature. The connection works fine, but when I connect with my phone running Android 2.3.6 to this VPN, I loose the Internet connection on my phone and am only able to access...
Network & Sharing
How can i share the wifi on my Win 7 computer with a server 2003?
I have a computer running Windows Server 2003 that i would like to connect to my computer running Windows 7 ultimate. i have done everything it says to in the videos and tutorials but i cannot get the server to connect to the internet. i can connect to it via remote desktop but it cannot connect to...
Network & Sharing
Cannot connet to server 2003 share; used to work
Hi all, My os: windows 7, asus laptop I have a laptop that was connected to a shared drive on a server 2003 box. Not using AD, just workgroups. I have a user account setup on the server, and as I said, it was connected fine and worked for many months. Now the connects was lost, so I...
Network & Sharing
offline share server
Hey guys, I have been wanting to create a massive offline storage space, something that is connected to a home network where all the devices connected to that network could access those files. Mainly I would like to accomplish this so I can back up all my movies onto my computer so that I can...
Network & Sharing


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:01.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App