Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: System restore 0x80042302

13 Sep 2016   #1
Alexk207

Windows 7 Home Premium x64
 
 
System restore 0x80042302

Today, when I wanted to do a system restore on my computer, system restore says that it's not functioning correctly on this system. It also says something about a Volume Shadow Copy Service component encoutered an unexpected error. Now I think I lost all of my restore points since my last system recovery performed this summer. Any suggestions to fix this?




Attached Images
System restore 0x80042302-screenshot_20160913193622.png 
My System SpecsSystem Spec
.
13 Sep 2016   #2
Lance1

Windows 7 Ultimate, Service Pack 1, 64 bit
 
 

Typing services.msc in the Run command. [Windows key + R] Look for Volume Shadow Copy service and double click on it. choose the startup type as automatic and click OK to apply the changes. Run System Restore.
My System SpecsSystem Spec
13 Sep 2016   #3
Alexk207

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Lance1 View Post
Typing services.msc in the Run command. [Windows key + R] Look for Volume Shadow Copy service and double click on it. choose the startup type as automatic and click OK to apply the changes. Run System Restore.
I don't see Volume Shadow Copy Service on the list.


Attached Files
File Type: txt powershell get-service.txt (9.5 KB, 7 views)
My System SpecsSystem Spec
.

14 Sep 2016   #4
Lance1

Windows 7 Ultimate, Service Pack 1, 64 bit
 
 

My System SpecsSystem Spec
14 Sep 2016   #5
Alexk207

Windows 7 Home Premium x64
 
 

Quote   Quote: Originally Posted by Lance1 View Post
What do I need to do to fix Volume Shadow Copy Service?
My System SpecsSystem Spec
14 Sep 2016   #6
Lance1

Windows 7 Ultimate, Service Pack 1, 64 bit
 
 

Quote   Quote: Originally Posted by Alexk207 View Post
Quote   Quote: Originally Posted by Lance1 View Post
What do I need to do to fix Volume Shadow Copy Service?
Courtesy of Windows Admin Guru


Create a batch file with the following content: Create a Notepad on your desktop and copy and past the below content. Save it as VSS.bat

Quote:
cd /d %windir%\system32

Net stop vss

Net stop swprv

regsvr32 ole32.dll

regsvr32 oleaut32.dll

regsvr32 vss_ps.dll

vssvc /register

regsvr32 /i swprv.dll

regsvr32 /i eventcls.dll

regsvr32 es.dll

regsvr32 stdprov.dll

regsvr32 vssui.dll

regsvr32 msxml.dll

regsvr32 msxml3.dll

regsvr32 msxml4.dll
Double click the batch file to run it. If you get one or both of the following errors:

dllregisterserver in swprv.dll failed:
regsvr32 /i swprv.dll returns the error "DLLInstall in swprv.dll
failed. Return Code was: 0x8000ffff"

dllregisterserver in es.dll failed


Followed by the recorded events in the event log with the event ID 12289:

Then there are three events in the event log all event ID 12289 source: VSS


Volume Shadow Copy Service error: Unexpected error RegOpenKeyExW(-2147483646,SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost,...). hr = 0x80070005.

And

Volume Shadow Copy Service error: Unexpected error CComModule::RegisterServer(TRUE). hr = 0x80020009.

And

Volume Shadow Copy Service error: Unexpected error RegOpenKeyExW(-2147483646,SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost,...). hr = 0x80070005.

Or when opening the Properties of the hard disk drive and opening the Shadow Copies tab you see the error:
Initialization failed

Error 0x8004230f: the shadow copy provider had an unexpected error while tring to process the specified operation

Or the Microsoft Software Shadow Copy Provider Service is not installed or had been uninstalled or is missing in the services list

Solution:

Run the following three Microsoft Hotfixes in this specific order, and reboot after EACH one has been installed for a total of three reboots:

1.KB 943669

2.KB 975928

3.KB 979457

Give Full Permission to Administrator and System account for the registry 'HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\SvcHost'

And again run the batch file to register the DLLs.

Hope this works for you!
My System SpecsSystem Spec
14 Sep 2016   #7
Alexk207

Windows 7 Home Premium x64
 
 

Btw, the hotfixes seem to be designed for Windows Server 2003, and I have Windows 7.
My System SpecsSystem Spec
Reply

 System restore 0x80042302




Thread Tools Search this Thread
Search this Thread:

Advanced Search




Similar help and support threads
Thread Forum
image restore 0x80042302
Trying to do image restore to blank hard drive but I keep getting message a volume shadow copy service component encounted an unexpected error check the application event log for more information (0x80042302).THe computer is a hp 6530b, I was running windows 7 pro. I have try just about everything...
Backup and Restore
0x80042302 on system restore..
I am having some problems with my laptop Windows 7 Home Premium pc. It has been working fine until one day after school I open my laptop and soon as I type in my password the brightness of the screen goes down ( turns dark. ) and im trying to make it bright by pressing on the brightness button on...
General Discussion
Cannot create system restore point (0x80042302)
Been trying for about 3 days to create a restore point but the same message keeps popping up. "A volume shadow copy service component encountered an unexpected error. Check the application even log for more information." I currently have no access to Internet on my laptop and Windows 7...
Backup and Restore
System Restore - Restore system settings and previous versions of file
estore system settings and previous versions of file is greyed out on my system, I may have disabled a required service for this, can anyone point me to the right direction for this? As I'm about to try the X-Fi MB2 mod again as the last time I tried it my system was messed up that it wont even...
Backup and Restore
0x80042302 System Image Restore Failed
So Gateway put a new HD in my laptop and sent it with working Win 7 HP. If I make a new System Image Backup to the same USB HDD, it restores fine. But when I try to restore the image I WANT, with all my programs installed, etc, it fails. Both images are on the same USB drive and Restore Center...
Backup and Restore


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:29.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App