Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Windows Backup error: "Element not found. (0x80070490)"

31 Jan 2010   #1

Windows 7 Ultimate
 
 
Windows Backup error: "Element not found. (0x80070490)"

Hi everyone

When trying to run a backup through the Windows Backup & Restore interface, I get this error:
Quote:
Windows could not disable the automatic backup job for the following reason:

Element not found. (0x80070490)

Try again.
My backup is setup specifically to run on demand, and I have disabled the option of automatic backups. This error pops up EVERY time I try to run a backup, it's not just a one-off. However, after pressing OK to this error (is appears twice, one after the other), Windows does its thing and gets on with the backup.

So I think there might be a problem with Windows Backup disabling its scheduled backup in the Task Scheduler, since it was previously told to backup on a schedule. So I opened Task Scheduler to see what I could find, and as soon as the program opens I'm greeted with the following error message:
Quote:
The selected task "{0}" no longer exists. To see current tasks, click Refresh.
When I press OK to that error message and press Refresh to reload the list of current tasks, it says in the status area: "Reading Data Failed".

Now, I'm not sure what's up with this. I presume it's something to do with Task Scheduler, since that's not working either. I'm thinking it's going to be something really simple like a Service isn't running that should be...

Having said that, the "Task Scheduler" service is set for automatic start and is currently running... In fact, I can't even change the settings to be anything else. I can't stop the service even if I wanted to. Which makes me more confused as to what it is!

I'd appreciate any help you can offer.

Thanks


My System SpecsSystem Spec
.

31 Jan 2010   #2

Windows 7 Ultimate
 
 

I've just tried the solution from http://www.sevenforums.com/performance-maintenance/10915-odd-task-scheduler-issues.html and rebooted.

Upon opening Task Scheduler straight after the reboot, it runs correctly as expected, with no errors.

When I open Windows Backup, it tells me that there's no backup set up (but there previously was). So I entered my backup configuration again, and disabled the backup schedule. Again, I got the same error message "Element not found". After having done this, opening Task Scheduler results in error messages again!

Windows Disk Defragmenter was also mentioned as a possible cause for the Task Scheduler errors. So I opened that after having cleared the TaskCache registry folder, and I'm told that another program was used to schedule the Defragmenter and I should click a button to remove the settings.

It looks like the 'solution' mentioned above has helped a lot of people. Unfortunately it doesn't do much for me, since as soon as Task Scheduler is fixed it gets broken again.... Aaah! :-(

Does anybody have any other suggestions? I'd be most appreciative.

Thank you
My System SpecsSystem Spec
Reply

 Windows Backup error: "Element not found. (0x80070490)"




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:03 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33