Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Browser problem

04 Oct 2010   #31
delmoon01

Windows 7 Ultimate x64
 
 

temporarily powering-off router might improve your browsing experience, its also a good idea to clear browser junk with some good system cleaner like reginout.


My System SpecsSystem Spec
.
Reply

 Browser problem




Thread Tools




Similar help and support threads
Thread Forum
Browser problem
Hi, I have an annoying problem on my browsers. When I use any of my browsers (tested chrome, safari, ie) I sometimes get error while browser is trying to load the page. The error Safari gave me had something to do with decoding or something like that. This is only happening in browsers and...
Browsers & Mail
IE 9 browser problem
i am using IE9 , a day before i installed Bit Defender 2013. before its installment there was no problem with browser but after installing it my defult web page turned to blank page when ever i open it. i tried a lot to set it to my choice web page but it automatically vanishes. i dont understand...
Browsers & Mail
Problem while in a browser
Anyone here had experienced while using Firefox as a browser and you're in a forum typing something when all of a sudden enterfactory opens a new tab, not just one but two tabs? I'm not sure if the system was infected with a rootkit or spyware of some sort. It happened thrice already today. I'm...
Browsers & Mail
Got a browser Problem...Anyone tell me what is this??
Some times my browser (chrome) got crashed then i click any thing like refresh its stay like strip on the screen...u can see in the attachment... I don't know what problem is that... can any one tell me what was that...either its browser fault or Os.... Thanks in advance... Mine is Lenovo...
Browsers & Mail
Browser problem?
The problem I’ve been getting is that all browsers (IE, Firefox, Chrome) stops loading pages after using it for sometime/clicking through a number of pages. There’s no error message, just a blank page with “Done” on the status bar. I could still ping those pages. My internet connection looks fine....
Browsers & Mail
Severe browser problem
Hey, this question mayor may not already be asked on here, but I couldn't find anything when I searched. I recently upgraded from Vista to 7 Ultimate, and I am loving the experience so far. But, I have ran into one slight problem, and that deals with the browser. I usually use Safari 4, or...
Browsers & Mail


Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd

All times are GMT -5. The time now is 09:48.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App