Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE + Flash + Limited Acc = No flash embedded vids


16 Oct 2010   #1

Windows 7 Ultimate x64 SP1 | OSX Lion 10.7 x64
 
 
IE + Flash + Limited Acc = No flash embedded vids

Hi all.

After a couple time, I noticed my IE stopped showing embedded flash-based videos. That was earlier than IE9 launch. I've then installed the "Beauty of the Web" to try out and was still without this feature. I didn't actually care much, but anyway, this bothers me enough to come here to ask.

Has anyone encountered this behavior? Just the embedded videos aren't playing, but going to YouTube website, I can watch the videos.

My Shockwave preferences are allowing plugin usage for any -- ie, * -- websites. Also, if I open an alternative browser -- Apple Safari 5 --, all works fine.

Finally, this user account is limited. If I open an IE9 window as Administrator, guess what? It works!

I am aware a couple weird stuff happens if you never log on your admin account -- IE, some Blizzard games does not install properly. But I have taken care of logging on to this local admin account to have things set up, but that was still a no-go.

Any clues or suggestions on where to look at? Or report a bug at Adobe website?

Thanks.


My System SpecsSystem Spec
.

16 Oct 2010   #2

Windows 7 Ultimate x64 SP1
 
 

Have you tried uninstalling and reinstalling Flash Player 10 AciveX?
My System SpecsSystem Spec
16 Oct 2010   #3

Windows 7 Ultimate x64 SP1 | OSX Lion 10.7 x64
 
 

Uh, yeah, that was my very first try (rebooting Windows 7 after running Adobe Uninstaller tool).

I've even tried an older Flash 10 I had around in my downloads folder.

No go.
My System SpecsSystem Spec
.


17 Oct 2010   #4

Windows 7 Ultimate x64 SP1
 
 

Sorry, you didn't mention you had attempted such in your initial post.

I dunno, uninstall IE9 and then reinstall?

How to Uninstall Internet Explorer 9

Or, have you already tried that as well? Just trying to help.
My System SpecsSystem Spec
17 Oct 2010   #5

Windows 7 Ultimate x64 SP1 | OSX Lion 10.7 x64
 
 

Hey Mike, thanks for the advices.

This behavior, in fact, was happening since before I installed IE9. Still, I have followed the IE9 removal procedures and it doesn't work in IE8 as well. Then I installed back IE9, no go.

There are other applications in the wild I use which also have a glitch or two because I run a limited user account. I guess Windows devs dislike their apps getting locked...

I am strongly believing this is a bug I should fill in with Adobe, just like the other three I've just submitted to other devs.

Now I am quite curious on how few people are running limited user accounts on his/her machines -- or am I the lucky guy which uses that much uncommon software?
My System SpecsSystem Spec
17 Oct 2010   #6

Windows 7 Ultimate x64 SP1
 
 

What I usually do in these cases is I'll promote the user encountering the issue to an Administrator level account. After that, I'll login to this user's account, which is now an administrative account. Once logged in, I will fully uninstall Flash Player using Adobe - Web Players the Flash Player Uninstaller at that link.

After that, I will close any currently open browsers and then log off this user. Then log back in as this same user and go back to adobe.com and install Flash Player in IE then in Firefox (or Safari or whatever alternative browser you use, if you do it in one of them, it will work in any alternative browser for the most part.) After that, I will log off and login to another administrative account and demote this user back to a limited account and then Flash will work for them.

Try these steps and see if they work for you or not.
My System SpecsSystem Spec
27 Jan 2011   #7

Windows 7 Ultimate x64 SP1 | OSX Lion 10.7 x64
 
 

Fixed!

Somehow the register key HKEY_CLASSES_ROOT\MIME\Database\Content Type\application/x-shockwave-flash had messed permissions. Deleting this key, closing all and every IE process (plus Flash* processes, if any), and then reinstalling Flash player solves this issue.

Kudos to this post: Fix: Flash 10.1 not working for limited users David Moisan's IT
My System SpecsSystem Spec
Reply

 IE + Flash + Limited Acc = No flash embedded vids




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 05:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33