Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Oops! This link appears to be broken!

17 Oct 2010   #1
LindsayPrower

IDK
 
 
Oops! This link appears to be broken!

"Oops! This link appears broken.DNS error occurred. Server cannot be found."This comes up on almost everything I try to go to now! I have no clue what to do, at times refreshing works, sometimes shutting down and restarting works but for the most part is doesn't. In particular a site, iscribble.net, refuses to load. This constant "Oops, this link appears broken or cannot be found" is driving me insane. Is there anything that can be done?I'd appreciate all the help I can get!My running system:HP LaptopLocal Dial-up Connectionand Windows 7 of courseIf anyone has any idea why this error report shows up, please tell me, and if you know how to fix it, I'd really appreciate it!


My System SpecsSystem Spec
.

17 Oct 2010   #2
johngalt

 

It could be a number of reasons, but typically, it sounds like your DNS settings are messed up.

have you installed any software that "will help you speed up your browsing" ?
My System SpecsSystem Spec
18 Oct 2010   #3
roncerr

Windows 8 Pro w/MC 32-bit
 
 

Here is a link to a tiny executable that allows you to choose from a number of fixes: SF IE Restorator - Troubleshooting General Issues with IE . Another thing that sometimes works is to reset (power off/on) your router and switch.
My System SpecsSystem Spec
.


18 Oct 2010   #4
LindsayPrower

IDK
 
 

@johngalt - There is/was a program on the desktop that says "Speed up your computer!" but I have no clue where it's installed or how to uninstall it.--@roncerr - Well I don't have a router, but I tried the other thing. I'll try it again but so far no luck, it's still not coorperating with me.
My System SpecsSystem Spec
Reply

 Oops! This link appears to be broken!




Thread Tools





Similar help and support threads
Thread Forum
Font Preview appears to be broken for some fonts.
I encounter this problem frequently with the Fonts item on the Control Panel, and I cannot figure out what is causing it. An example of a font for which it occurs is Script Regular. If I try to preview it, only the first two small size lines which show all the characters of the font seem to...
General Discussion
Broken Link
Hi Folks, its at http://www.sevenforums.com/tutorials/257-windows-7-tutorial-index-2.html#post1079
Chillout Room
Word 2007 - Works converter appears to be broken by latest updates
Until recently I've been able to open old MS Works (.wps) files in Word 2007, but since installing the latest Windows updates on 11 April I now get a message saying that I need a newer version of the conversion tool, with a link to go and download it. I tried this, but the only file I can find...
Microsoft Office
Rc 7100 -- XP connectivity appears STILL to be broken
Hi all We still seem to have the slight Networking glitch when trying to share / connect to XP machines from W7. If your W7 machine has a different Userid / Password combination from the XP machine you want to connect to then the initial LOGON screen prompting for a UserID / Password is...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:21.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App