Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: No internet connection but Skype works


31 Oct 2010   #1

Windows 7 Ultimate 64 bit
 
 
No internet connection but Skype works

Hello,
Two days ago my computer gave me a blue screen of death (not the first time). Ever since that restart my internet says I'm connected but nothing can access the internet (Except for skype), the fingerprint sensor also does not work anymore. I thought it may be a hardware issue but system scans say everything is fine and with skype working it leads be to believe that it's not a hardware issue. I looked through all the forums and google results but none of the fixes seem to fix my problem.
I have reset the winsock, tried a public DNS, turned use a proxy on in internet options, I have the same problem when I take my laptop into work and connect wired or wireless to that network as well (fixed IP or dynamic) so it's not the ISP, I cannot ping anything neither google.com nor localhost, Windows troubleshoot solution does not find any errors, and the error reporting or windows update cannot connect to the internet. Torrents, Browsers(Firefox,IE(both 64bit and 32bit),Chrome), Mail, Windows, Microsoft Security Essentials cannot connect either; only skype seems to work.
I use MSE so I don't have any other antivirus or malware program running. I was watching a replay of a game off the internet and also had started an update of Adobe CS5 (the blue screen came about 15min into the game) so I wasn't sure if Adobe finished. Since that was the only thing I had newly installed or changed before having the problem, I have uninstalled the entire Adobe CS5 suite and still no fix.
Windows 7 Ultimate 64bit was upgraded from Vista on the computer over a year ago no problems. I unfortunately turned off system restore a long time ago and forgot to turn it back on (set the space limit to zero), so I can't perform a restore, and so the only option I can see is a format which I really really would like to avoid.
If anyone knows of a fix that I have overlooked on the forum please point me to the right direction or if you have any ideas on how to fix it THANKS.

My System SpecsSystem Spec
.

31 Oct 2010   #2

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

If Skype works, then you do have Internet connection. But you may have a problem with DNS.

Start a command prompt. Then type:

ping 128.163.1.6

Does that work?

If yes, then type:

ping "www.cnet.com" (without the quotes)

If yes to the first, but not to the second, let me know.
My System SpecsSystem Spec
31 Oct 2010   #3

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

Oh, after all that, at the command prompt, type:

ipconfig /all > sf.txt

upload sf.txt to this forum
My System SpecsSystem Spec
.


31 Oct 2010   #4

 
 

also, if your connected wirelessly then try deleting the network then re-connecting.
Note   Note
in Network and Sharing center, click 'Manage wireless networks' then click the network in question then click smoote
My System SpecsSystem Spec
31 Oct 2010   #5

 
 

doh! Click remove, damn mobile predictive txt! Lol
My System SpecsSystem Spec
31 Oct 2010   #6

Windows 7 Ultimate 64 bit
 
 

Ping 128.163.1.6 works
ping "www.cnet.com" (without quotes) does not
ping localhost does not
ping 127.0.0.1 works

I have tried to switch the DNS to the google public DNS instead of automatic but that didn't fix the problem either.

I've attached sf.txt


Attached Files
File Type: txt sf.txt (4.0 KB, 685 views)
My System SpecsSystem Spec
31 Oct 2010   #7

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

So we now know it's a DNS issue.

So you tried hard coding the DNS, rebooted, and no success?
My System SpecsSystem Spec
31 Oct 2010   #8

Windows 7 Ultimate 64 bit
 
 

Quote   Quote: Originally Posted by Orbital Shark View Post
also, if your connected wirelessly then try deleting the network then re-connecting.
Note   Note
in Network and Sharing center, click 'Manage wireless networks' then click the network in question then click smoote
Deleted and reconnected no luck. I have to reiterate that connecting at my work to that wireless network also resulted in no internet but a working skype and even using the wired fixed ip internet connection yielded the same result.
My System SpecsSystem Spec
31 Oct 2010   #9

Systems 1 and 2: Windows 7 Enterprise x64, Win 8 Developer
 
 

After further thought, maybe a driver was corrupted. Try to find a newer network driver to update to, uninstall you current driver.

Do you have the Touchsmart tx2z 1000 or 1300?

Product search results
My System SpecsSystem Spec
31 Oct 2010   #10

 
 

It could be that the router needs rebooting.
Note   Note
consult your router documentation for info on rebooting
My System SpecsSystem Spec
Reply

 No internet connection but Skype works




Thread Tools




Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 09:42 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33