Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.

Windows 7: Slow Internet Browsing Problem

18 Feb 2010   #41

Windows 7 Ultimate
fixed, my ISP was lying.

Well, after several phone calls to my ISP and trying a bunch of stuff that didn't work they sent some techs out to test the lines and connection. After the senior idiot repeated the party line that nothing was wrong with their service and I should go back to XP because win7 wasn't supported, .etc ... the younger guy quietly mentioned in English that two of their hubs had been down for a month and most of the people in my part of the city were having the same problem. It seems they've also oversold their bandwidth and are throttling connections during working hours.
It still doesn't explain how I could get 130kbps torrent downloads and smooth video streams, but couldn't open Google image search...
Anyway, I called a smaller company today, got hooked into their LAN and presto everything is fine again.
That's how it works in Bulgaria I guess, good luck to you guys still having problems elsewhere and sorry I couldn't help more.

My System SpecsSystem Spec
06 Apr 2011   #42

Windows 7
Very slow HTTP browsing on couple of Sites

I have experienced this problem on couple of sites, where the page was traking several minutes or didn't load at all, following the recomendations on this site I changed the parameter "congestionprovider" from none to CTCP

c:\netsh int tcp set global congestionprovider=ctcp

After this the I was able to open the site without any delay

Not sure what the implications are of this field but so far is working well
My System SpecsSystem Spec
06 Jan 2013   #43

windows 7 professional
Thanks I think I'm through

Quote   Quote: Originally Posted by Jacee View Post
AVG has bundled "LinkScanner" in their product. You can either disable it or uninstall it. This part of AVG scans the web pages that you browse to see if they're okay. It's most likely the cause of your slow browsing.

Read the faq here:
AVG Free | LinkScanner | FAQ

If you want to keep AVG, then I would recommend uninstalling it, and reinstalling without 'linkscanner'.
seems this was helpful to me. Thanks Jacee
My System SpecsSystem Spec


 Slow Internet Browsing Problem

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Similar help and support threads
Thread Forum
Slow internet browsing
I all of a sudden have slow internet browsing after getting messages for java updates. I disabled the Java add on so I don't get the message anymore but the browsing using either IE or Google is slow. I deleted temporary internet files and cookies and checked with my ISP. I ran malwarebytes scan...
Browsers & Mail
Slow Internet Browsing
My machine is presario cq62, with an intel i5 processor. i do experiencing an extraordinary slowness in both browsing and downloading. I Tried re-installing OS several times, and was not successful. I'm using avg antivirus package. I'm using Google crome as current browser. Cooling fan is also...
Browsers & Mail
Internet browsing slow with IE9
When I use IE9 to browse the internet it sometimes is very slow. I have run an internet speed test program ( which hangs when testing IE9. I then started Chrome and the internet browsing was fast. I ran the speed test program and the speed was what I expected. I switched...
Browsers & Mail
slow internet browsing
At my home network my pc runs just nicely. But today I moved it to my friends place and for some reason all surfing is really slow, like takes up to 30-40 seconds to load. Using my laptop computer it loads in about a second on the same network. I am on a 4mb/500kb connection and...
Network & Sharing
slow download and internet browsing
Hi I seem to have joined the many that are having problems with slow download speeds using Windows 7. I recently bought a well speced HP Pavillion with Windows 7 64-bit. Since I turned it on for the first time I have painfully slow download speeds. A broadband speed test showed download speed...
Network & Sharing
VERY Slow internet browsing speed.
I installed windows 7 64-bit the other day and i've noticed that browsing the internet is VERY difficult. Sometimes pages will only half load (missing graphics etc) or not load at all. I have tried chrome, IE and firefox and they all have the same issues. As another example, no youtube videos load...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 10:46.

Twitter Facebook Google+

Windows 7 Forums

Seven Forums Android App Seven Forums IOS App