Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Internet Browsing Problem


16 Jun 2009   #1

Windows 7 Ultimate 64bit
 
 
Slow Internet Browsing Problem

Hi, I installed Windows 7 couple weeks ago and found out that the Internet browsing is really really slow. I reinstalled it twice and the same thing is happening. My computer has 4GB of RAMS and on E8400 processor so I dont think it's my computer's problem. I have tried IE8, Firefox, Google Chrome and all of them are slow.

Is there anything I can do?
Please help out.

thanks

ps: my download speed has no problem. fast as usual. it's just when I am browsing the internet sites using IE, FF, and GC.

My laptop is on Win XP and its browsing fast but my desktop with Windows 7 is not. So there must be a problem with Windows 7 for me.

My System SpecsSystem Spec
.

16 Jun 2009   #2

 
 

Hi shun86, welcome to the forums.

Are you running any bit torrent client that is downloading when you are browsing?

If so have a look here http://www.sevenforums.com/network-i...py-medium.html and see if altering the setting changes your browsing experience.
My System SpecsSystem Spec
16 Jun 2009   #3

Windows 7 Ultimate 64bit
 
 

No, I wasn't downloading anything. Just straight web browsing.
Don't know why it's happening.

btw: thanks for the welcome
My System SpecsSystem Spec
.


16 Jun 2009   #4

Win 8 Release candidate 8400
 
 

Quote   Quote: Originally Posted by shun86 View Post
Hi, I installed Windows 7 couple weeks ago and found out that the Internet browsing is really really slow. I reinstalled it twice and the same thing is happening. My computer has 4GB of RAMS and on E8400 processor so I dont think it's my computer's problem. I have tried IE8, Firefox, Google Chrome and all of them are slow.

Is there anything I can do?
Please help out.

thanks

ps: my download speed has no problem. fast as usual. it's just when I am browsing the internet sites using IE, FF, and GC.

My laptop is on Win XP and its browsing fast but my desktop with Windows 7 is not. So there must be a problem with Windows 7 for me.
shun86
Hi and welcome to SF. It would help if you filled out your system specs. I wondered what virus checker you have installed and what ver of win 7 (32 or 64)
Waiting for info

Ken
My System SpecsSystem Spec
16 Jun 2009   #5

Windows 7 Ultimate 64bit
 
 

Quote   Quote: Originally Posted by zigzag3143 View Post
shun86
Hi and welcome to SF. It would help if you filled out your system specs. I wondered what virus checker you have installed and what ver of win 7 (32 or 64)
Waiting for info

Ken
Intel Core 2 Duo E8400 @ 3.00Ghz
4GB DDR3 RAM
NVDIA GeForce 9500 GT
64-Bit Operating System

Running AVG 8.5

thanks
My System SpecsSystem Spec
16 Jun 2009   #6

 
 

Personally i'd swap AVG for Avast! i find the memory usage alone is much better than any other AV i've used to date.
My System SpecsSystem Spec
16 Jun 2009   #7

Windows 7 Ultimate 64bit
 
 

so you mean the problem is the Antivirus programs??
I don't know if it's a 32 or 64 antivirus program...
My System SpecsSystem Spec
16 Jun 2009   #8

Windows 7 Ultimate 64bit
 
 

I just uninstalll AVG and installed Avast and it is still really slow....
No one seem to have this problem except for me lol...
wonder what's wrong
My System SpecsSystem Spec
18 Jun 2009   #9

Windows 7 Ultimate 64bit
 
 

does anyone else know what's wrong?
please help out...
or should I just go back to XP 64bit or Vista 64bit?
My System SpecsSystem Spec
18 Jun 2009   #10
Microsoft MVP

Windows 7 Ultimate 32bit SP1
 
 

AVG has bundled "LinkScanner" in their product. You can either disable it or uninstall it. This part of AVG scans the web pages that you browse to see if they're okay. It's most likely the cause of your slow browsing.

Read the faq here:
http://free.avg.com/faq.num-1241#faq_1241

If you want to keep AVG, then I would recommend uninstalling it, and reinstalling without 'linkscanner'.
My System SpecsSystem Spec
Reply

 Slow Internet Browsing Problem




Thread Tools



Similar help and support threads for2: Slow Internet Browsing Problem
Thread Forum
Solved Slow internet browsing Browsers & Mail
Slow Internet Browsing Browsers & Mail
Windows 7 slow file and internet browsing. Browsers & Mail
Internet browsing slow with IE9 Browsers & Mail
slow internet browsing Network & Sharing
slow download and internet browsing Network & Sharing
VERY Slow internet browsing speed. Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 04:00 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33