Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Can't activate links in emails

28 Jan 2011   #1
545Frosty

Windows 7 Home Premium Edition (64-bit)
 
 
Can't activate links in emails

I can't see any place else to put this problem. I am having trouble with not being able to go to links I receive in emails. This problem just started today. I don't know if I went to a link yesterday that caused my problem or not. Anyhow, when I click on a link in an email, nothing happens. I tried to cut and paste the link to get to it, but that doesn't help either. What's wrong? How do I fix it? I'm not very computer savy.
Another thing is that, I just found out that my Spell Check doesn't work now either.


My System SpecsSystem Spec
28 Jan 2011   #2
mikedl

Windows 7 Ultimate x64 SP1
 
 

Hi, 545Frosty, welcome to the Seven Forums!

A few questions first:

Which email client are you using; Windows Live Mail, Outlook, Thunderbird?

When you say your spell check is not working, do you mean in the email client or the browser?

Which browser are you using?
My System SpecsSystem Spec
28 Jan 2011   #3
545Frosty

Windows 7 Home Premium Edition (64-bit)
 
 

I use PeoplePC to get my email.
When I click Spell Check, it seems like the screen freezes for a couple of minutes, but nothing else happens. The Spell Check doesn't open.
I don't even know what a browser is. All I know is I have PeoplePC to get online. I do have Windows Live though to get some of my emails through hotmail. Does that help?
My System SpecsSystem Spec
28 Jan 2011   #4
mikedl

Windows 7 Ultimate x64 SP1
 
 

Hi, again, 545Frosty!

I'm not familiar with PeoplePC for email and, therefore, cannot explain why your links aren't working or provide a way to fix it.

I really apologize.

Is PeoplePC provided by your ISP? If so, give them a call as they will be much more familiar with your issue and should be able to help.
My System SpecsSystem Spec
28 Jan 2011   #5
545Frosty

Windows 7 Home Premium Edition (64-bit)
 
 

When I called PeoplePC about the problem earlier today, the man I talked to just told me to cut and paste the link into the search box. He didn't know why I wasn't able to click the links from within the email either. I think I went to a site yesterday, and that site transmitted some bug to my computer. I'll probably have to take it to the store I bought it from to have it fixed. Unless I can find another way to do it. I don't want to take a chance on losing the things I have on it.
My System SpecsSystem Spec
28 Jan 2011   #6
mikedl

Windows 7 Ultimate x64 SP1
 
 

Hi, 545Frosty!

Download and run Malware Bytes.

Run it for a scan and let us know what you find.

It's just an extra precaution against malware and I use it weekly in addition to my standard resident AV.
My System SpecsSystem Spec
Reply

 Can't activate links in emails




Thread Tools





Similar help and support threads
Thread Forum
Can't activate links in WLM nor open enclosures
There is no response when I click on links. If enclosure is an Adobe PDF I can open them when I specify "Open with Adobe". Will you be good enough to provide a fix for this please.
Browsers & Mail
Links in emails opening behind Windows Live Mail
This is a fairly recent problem. When I click on a link in an email in Windows Live Mail, the page opens up behind WLM. It always used to open up in front. My default browser is Chrome. Anybody know how I can change it back, please?
Browsers & Mail
Unable to open links in emails - Windows 10
Although I can access my emails through IE and open them okay, if I click on a hyper-link within the email it doesn't connect with the linked site. The header remains in view on screen with the Connecting tab on show, but the screen underneath is blank - white. I have read other comments on...
Browsers & Mail
links in EMails
For some reason all links in EMails keep telling me there is no program associated with link. Why has this suddenly started occurring, its annoying to lose links to sites/articles i require.????
Browsers & Mail
Opening links inside emails in Outlook 2007
For some reason, suddenly, I can't seem to open links inside emails that I get in Outlook 2007 due to some security restrictions that I can't find or are unaware of. Anyone know how to correct this?
Microsoft Office
Activate HTML links from MS outlook in the BG
Hello FELLAS, This is a quote from a question a I asked in Maxthon2 forum: Since I couldn't find an option to put either IE8 or Maxthon2 always in the background I roll back to Outlook and I think that putting him always in front (while I decide to) can solve the problem aswell. Is there...
Microsoft Office

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 11:53.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App