Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: IE9 - Problem with javascript


21 Mar 2011   #11

Windows 7 / Windows 8
 
 

This problem concerns javascript, I wrote that I use jQuery.

My System SpecsSystem Spec
.

21 Mar 2011   #12

Windows 7 / Windows 8
 
 

I addded to site code:

Code:
    <meta http-equiv="X-UA-Compatible" content="IE=9" />
and the problem disappeared.
My System SpecsSystem Spec
21 May 2011   #13

Windows 7 Home 64 bit
 
 

Quote   Quote: Originally Posted by lukasamd View Post
I addded to site code:

Code:
    <meta http-equiv="X-UA-Compatible" content="IE=9" />
and the problem disappeared.
I'm having the exact same problem, but this fix didn't work.

I concede though that I am in the midst of writing a new site, so at first, I thought the problem was only with my coding. I haven't confirmed if the problem is mine or IE9 yet.

Usually I work under Chrome and all my buttons function fine. At first, I had a problem because I had never added multiple buttons to a single page before, so when I first added a second button to the page, I realized the problem was that my buttons weren't unique. Spent a week figuring that out and now all my new pages work fine on Chrome, each button having a unique id (but the same class).

Then I got a new computer this week, Windows 7 Home 64 bit with IE9, Dell. So I tested my site using IE9. On the page where I have only one button, it works fine. On the page where I have multiple buttons, although they are unique, they aren't being recognized by IE9. I click and nothing happens. Yet it works fine under Chrome.

At least that's my interpretation of the problem right now. Maybe somebody else knows more...

I am using a line similar to this:

<a id="_post_btt_109" class="button" href="javascript:void(0)">Post It!</a>

Is the void cancelling the action in IE9??
My System SpecsSystem Spec
.


24 Aug 2012   #14

Windows 7 Professional 64bit
 
 

I have found IE9 to be very finicky about where your JavaScript resides in your page. Try moving your JavaScript to the bottom of your code and see if that helps, especially in the case where a script does not work when a page is first loaded, but then it does work after a refresh.
My System SpecsSystem Spec
Reply

 IE9 - Problem with javascript




Thread Tools



Similar help and support threads for2: IE9 - Problem with javascript
Thread Forum
javascript problem crops up Browsers & Mail
Solved Javascript image problem Browsers & Mail
Help with Javascript? Chillout Room
JavaScript help... Chillout Room
Javascript error Browsers & Mail
javascript Chillout Room
JavaScript Chillout Room

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 03:44 PM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33