Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Internet Explorer makes the System slow

04 Jul 2009   #1
GladwinRam

Windows 7 Build 7100
 
 
Internet Explorer makes the System slow

Dear Friends,

I have Windows 7 (RC). The System is running fine. But my problem is that whenever I connect to the Internet, the entire System becomes very slow. It becomes hard to operate, the System responds to every action very slowly.

When I checked the Performance in Task Manager, the memory usage without the Internet is between 480 to 520 MB. Is this normal? But when I connect to the Internet, it increases above 680 MB. And the maximum memory usage is by IE; above 135 MB.

Kindly help.

Thank you.


My System SpecsSystem Spec
.

04 Jul 2009   #2
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by GladwinRam View Post
Dear Friends,

I have Windows 7 (RC). The System is running fine. But my problem is that whenever I connect to the Internet, the entire System becomes very slow. It becomes hard to operate, the System responds to every action very slowly.

When I checked the Performance in Task Manager, the memory usage without the Internet is between 480 to 520 MB. Is this normal? But when I connect to the Internet, it increases above 680 MB. And the maximum memory usage is by IE; above 135 MB.

Kindly help.

Thank you.
Hi Gladwin,

Thanks for the post. I just opened IE on my system (I am using 7264) and the memory usage increase was close to 100MB so it may be ok where that is concerned. The basic specs for Win7 (as per Microsoft) are 1 GB Ram so you are fine on the RAM. Since your RAM is a little low....I would imagine that it would be using that much (unless someone here has a better knowledge of memory usage at that level). Could you tell us your flavor of Windows 7 (x86 or x64)....was it a clean install or upgrade and when you open IE, is it maximized?
My System SpecsSystem Spec
04 Jul 2009   #3
GladwinRam

Windows 7 Build 7100
 
 

Thank you Zidane.

I'm using Windows 7 (x86) clean install. And yes, the IE is maximized when it's launched.
My System SpecsSystem Spec
.


04 Jul 2009   #4
Zidane24

Windows 7 Home Premium x64 - Mac OS X 10.6.4 x64
 
 

Quote   Quote: Originally Posted by GladwinRam View Post
Thank you Zidane.

I'm using Windows 7 (x86) clean install. And yes, the IE is maximized when it's launched.
I always like clean installs....I swear upgrading causes issues....if IE is not maximized, is it still being extremely slow? and does any other application that uses a lot of RAM (like Windows Media Center) cause an extreme amount of lag....also go ahead and check WU for updates

EDIT: ANDDDD One more thing go ahead and install another browser (such as Firefox) and see if that browser slows down terribly....hopefully one of these will give us the answer we need.
My System SpecsSystem Spec
Reply

 Internet Explorer makes the System slow




Thread Tools





Similar help and support threads
Thread Forum
Internet Explorer 10 running very slow
My IE10 searches are is running so slow as to be almost unbearable. I having starting using Chrome for searches instead since that is running normally. I am using the Google Toolbar to initiate searches on IE10 as I have been forever with no problems. Not aware of any issue that may have caused...
Browsers & Mail
JS Library XMLHttpRequest makes Internet Explorer freeze
Hi all, I'm using an online application which utitilises XMLHttpRequest from the JS Library to add new information to the screen without the need of refreshing the browser. On a certain point, when calling for the XMLHttpRequest, the browser is stuck on "Loading" and it won't move.. I was...
Browsers & Mail
Internet Explorer 9 - sporadically slow
Hi guys, I have a really strange issue with Internet Explorer 9. 95% of the time I launch it and everything is pretty much instant. However occasionally it will hang for a few secs on 'waiting for reply'. Tends to happen to all web pages but more specifically noticed it on Google.com and...
Browsers & Mail
Windows update service makes system extremely slow
One of my users is having a severe problem. When automatic updates is enabled on this machine, the hard drive thrashes and makes the machine extremely slow. Slow as in clicks take around a minute to register. Disabling automatic updates corrects the problem. Has anyone else had this problem...
Windows Updates & Activation
Internet Explorer 32 Bit Running Slow
Just thought I'd share this information. I've purchased a new machine with Windows 7. Everything was fine, including Internet Explorer (8) 64 bit, until I needed to access some web functions that seemed only to be available in the 32 bit version of Explorer. Upon starting the 32 bit version...
Browsers & Mail
Utorrent makes internet slow,even after it's not opened
Hi, I noticed today that after I closed Utorrent and tried to ping a gameserver on Steam, I saw that my ping on all server was above 1000 ms, my ping is usually at 60-150, And this only happens in Windows 7 :S The only solution for me is to restart the computer.. Translation from the images:...
Network & Sharing

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 01:11.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App