Windows 7 Forums
Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.



Windows 7: Strange Problem - IE 9 Can't Show Certain Websites

04 Jun 2011   #1

Windows 7 Home Premium 64bit
 
 
Strange Problem - IE 9 Can't Show Certain Websites

Hi- I just registered here, mainly because I can't even access the microsoft help forums anymore. This problem suddenly appeared yesterday, and I've spent most of my time since then trying to solve it.
I have Windows 7 Home 64 bit, and I'm using IE9 32 bit. Suddenly yesterday morning IE9 could no longer display pages from certain websites . It connects and tries to fetch the page, but after a minute or two it gives up and displays the standard "Internet Explorer Cannot Display This Page" message.
Here are some of the websites that IE9 can no longer show:
photobucket.com
barnesandnoble.com
microsoft.com
mail.yahoo.com
Strangely, I can still reach some Yahoo sites, and appear to be signed in, and can even see my mail box on my MyYahoo page, but can't go directly to it.
I've experimented with different settings for IE options, popupblocker, active-x, flash, but nothing helps. I've also added these sites to my list of trusted sites in the security tab, which has the lowest possible security settings, but that doesn't help either.
Another thing I've discovered is that IE9 appears to download part of the source code for these pages but not all of it.
I can still access most sites as usual. It's just particular sites such as those I listed above that have the problem.
Does anyone have any idea what could cause this?
Thank you

My System SpecsSystem Spec
.

04 Jun 2011   #2

XP Pro & Vista Home Premium (x86); Windows Ultimate 7600 x64 Retail
 
 

Had IE9 been working correctly before and the problem just started?

If so my first step would be a full system scan with Malwarebytes' Anti-Malware Free Download and Reviews - Fileforum

If it had never worked you can remove it and re-install.....
My System SpecsSystem Spec
04 Jun 2011   #3

Windows 7 Home Premium 64bit
 
 

Thanks for your quick reply.
Yes, it had been working correctly before. I noticed the problem when I started browsing early yesterday morning, so it must have appeared during the night.

I ran Microsoft Security Essentials full scan yesterday afternoon but it didn't find any viruses or malware. Not ready to download and run another malware detection program yet - maybe later.
My System SpecsSystem Spec
.


04 Jun 2011   #4

Windows 7 Home Premium 64 bit
 
 

Does it happen in another browser, Firefox, Chrome, or Opera?
Why not download one of those other browsers and see if you can navigate to those sites. Then you'll know it's IE itself.

Also, do you use a router?

And finally, try using OpenDNS | DNS-Based Web Security.
My System SpecsSystem Spec
04 Jun 2011   #5

Windows 7 Home Premium 64bit
 
 

Thanks for the reply. I'm not quite ready to install another browser yet - prefer to use only one browser for everything.

Also, I just tried to visit OpenDNS | DNS-Based Web Security as you suggested, but it's apparently one the sites I can't reach.
Also, no router.
Thanks again
My System SpecsSystem Spec
04 Jun 2011   #6

Windows 7 Home Premium 64bit
 
 

Well the problem seems to be solved. I turned off the computer, then unplugged the power to the modem for about two minutes. Now, after re-booting, IE9 is back to normal, and I can visit all of those particular websites again.

I remembered that a thunderstorm storm several years ago had caused some strange internet problems and someone told me that static electricity can build up in a modem and affect performance, and that the solution is to cut off power for a couple of minutes to let it discharge..

So that appears to be what happened this time too. What I don't understand is why only particular websites were affected. I tried repeatedly to reach them and they consistently failed to load, whereas other sites always loaded. Strange !

But anyway, the problem appears to be solved.
Thanks again.
My System SpecsSystem Spec
Reply

 Strange Problem - IE 9 Can't Show Certain Websites





Thread Tools



Similar help and support threads for2: Strange Problem - IE 9 Can't Show Certain Websites
Thread Forum
Google toolbar won't show in pinned websites Browsers & Mail
IE9 wont show certain websites Browsers & Mail
Strange problem loading images on many websites Browsers & Mail
Why would Firefox show "waiting for" some websites? Browsers & Mail
IE8/Firefox show some websites in italics! Browsers & Mail
Problem accessing websites! Browsers & Mail
Strange show desktop button General Discussion

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 07:19 AM.
Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App
  

1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33