Windows 7 Forums

Welcome to Windows 7 Forums. Our forum is dedicated to helping you find support and solutions for any problems regarding your Windows 7 PC be it Dell, HP, Acer, Asus or a custom build. We also provide an extensive Windows 7 tutorial section that covers a wide range of tips and tricks.


Windows 7: Slow Browsers Startup

09 Jul 2011   #1
af1992

Windows 7 Home Premium 64Bit
 
 
Slow Browsers Startup

Hi, Recently I have noticed that IE9 and Firefox 5 take a really long time to load up on startup, whereas Opera loads up instantly on startup. I have tried disabling all add-ons for both these browsers, as well as disabling all startup entries to see if these have an effect. I have also ran CCleaner, defragmented my hard drive and registry as well as cleaned them. There isnt a problem with my windows 7 startup as it is usually loaded fully in 5 seconds of the welcome screen, with all startup entries enabled, there just seems to be something clashing with both these browsers on the first startup, after the first startup these browsers load instantly within clicking their shortcuts. Help please!


My System SpecsSystem Spec
.

09 Jul 2011   #2
speedgamer01

Windows 7 Enterprise x64 no SP
 
 

Do you remember any plugin installation like DivX in the near past?
My System SpecsSystem Spec
09 Jul 2011   #3
af1992

Windows 7 Home Premium 64Bit
 
 

yes, I have divx vod helper plug in enabled in firefox and divx browser plug in object enabled in internet explorer, I'm going to disable them and see what the outcome is
My System SpecsSystem Spec
.


09 Jul 2011   #4
af1992

Windows 7 Home Premium 64Bit
 
 

Disabled all Divx Addons but problem still persists
My System SpecsSystem Spec
09 Jul 2011   #5
boohbah

Microsoft Windows 7 Home Premium 64-bit 7600
 
 

for firefox i can reccomend speedyfox, it works, you have to run it now and again when you see firefox start to slow up.
SpeedyFox - Boost Firefox in a Single Click! | CRYSTALIDEA Software
My System SpecsSystem Spec
09 Jul 2011   #6
af1992

Windows 7 Home Premium 64Bit
 
 

I already have a program called firefox preloader and that still hasnt helped. I just don't understand when opera and chrome load instantly yet these two take forever on their first start up!
My System SpecsSystem Spec
09 Jul 2011   #7
darkfriday

Windows 7 Home Prem x32
 
 

Quote   Quote: Originally Posted by boohbah View Post
for firefox i can reccomend speedyfox, it works, you have to run it now and again when you see firefox start to slow up.
SpeedyFox - Boost Firefox in a Single Click! | CRYSTALIDEA Software

TY
My System SpecsSystem Spec
Reply

 Slow Browsers Startup




Thread Tools





Similar help and support threads
Thread Forum
Should I run Ccleaner if browsers are slow?
Should I run Ccleaner, if my browsers are slow? I have an AMD processor. But, my internet browser seems slow and choppy while browsing the web. I use IE 11, Google Chrome, and AOL Desktop.
Browsers & Mail
Browsers Vey Slow
Last week I had a catastrophic failure. I dont need to get into details but bottom line is that Windows 7 (x64) had to be completely installed from scratch. My buddy at the shop had the foresight to save all my data files before formatting and installing. Everything is back running well except my...
Browsers & Mail
Windows Explorer and now Browsers slow / timing out
These two issues may or may not be related, but both seem to have started recently: Windows Explorer (not Internet explorer) just sits there for ages (several minutes) before actually displaying the contents of my computer. The structure on the left is all there but the right side where all...
Performance & Maintenance
Suddenly very slow browsing, all browsers
Since two days ago all my browsers function very slow. A new tab can take 15 seconds to open, typing in addressbar has very long delay (I type an address and hit Enter, it takes up to 20 seconds for first letter to appear, then other letters appear one in every 0.5 to 1 second). Typing this post...
Browsers & Mail
Browsers Slow, Torrent speed fine.
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems...
Network & Sharing
Browsers Slow, Torrent speed fine
Hi All, I have just upgraded to Win 7 Ultimate x64, I had no problems installing Win 7 (fresh Install) The computer is a I5 2500k, Asus P8P67 m/b, GTX 560ti GPU, 8g ram, OCZ 120gb ssd, I haven't connected the 2 tb storage just yet, Not sure if you need that info or not. The Problems seems...
Browsers & Mail

Our Sites

Site Links

About Us

Find Us

Windows 7 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 7" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd

All times are GMT -5. The time now is 06:23.

Twitter Facebook Google+



Windows 7 Forums

Seven Forums Android App Seven Forums IOS App